Flash Error on Every Drive I've Used

I’m trying to flash the latest version of tails onto a flash drive or an SD card, neither has worked thus far. After reinstalling Etcher multiple times, downloading the image multiple times, and searching the forums to find nothing useful, I get the same error message.

"Attention

Something went wrong. If it is a compressed image, please check that the archive is not corrupted.

spawn
D:(file location here)"

Help would be appreciated, disappointed that such a simple tool doesn’t do what it was designed for.

Hey there,

Welcome to the forums.

Can you please provide some more details please:

  1. Which operating system are you using etcher on?
  2. which version of etcher are you using?
  3. Which tails OS image did you download? There are 3 variants: for usb sticks, dvd and virtual machines

Thanks for confirming

  1. Currently using Windows 10
  2. Etcher V 1.5.101
  3. I downloaded the USB Stick image for Tails

Hi again, thanks for the useful information!

In order to better diagnose the problem. Could you perform the following operations and let us know the results?

  • Could you verify the downloaded usb image using the process described in the tails website. This can help us discard any actual corruption problems.
  • Could you retry flashing the image with the Etcher devtools panel open (Control + Alt + I) and share with us any error messages that appear in the console? This might help us have more details on the underlying cause of the error.

Thanks again for your help