[SOLVED] Why ist the changelog mentioning 1.5.110 and the downloadable version changes from 1.5.109 to 1.5.105?

Just a question …


Hi Andreas, can you clarify what you mean? What OS is this for? I can only see 1.5.110 offered as a download from balena.io/etcher right now.

I think I understand – in fact I’m seeing 1.5.105 available for download. The CHANGELOG is typically ahead of the version offered for download, it takes a while for a release to be made available but the CHANGELOG tracks all changes in the project repository.

The time difference of the release available for download and the latest release appears to be significant, so I asked the Etcher team and it seems we took versions 1.5.106-1.5.110 down due to a serious bug that cropped in.

Ok, thx for the info … what kind of bug is this?

Is it filed here?: https://github.com/balena-io/etcher/issues

I am using 15.109 - do you recommend to roll back to 1.5.105?



We would recommend using the latest version of Etcher for your platform, which would 1.5.111 (https://www.balena.io/etcher/). I’m not sure of the specific bug that led to the removal of version 1.5.106-1.5.110, but this thread highlights some issues with those versions.


Thanks you so much - great support!!!

Glad you solved the problem!