SD flash failed at the start of validation

I’m on Windows 10. I was trying to flash the ev3micropython image to a SanDisk Ultra SD card. The flash was completed, then when it started the validation it it said “flash failed”. I couldn’t find an error message and I don’t know how to open the console on Windows.
I’ve tried multiple SD cards, multiple adapters, and two different computers and I keep getting the same fail at the same spot every time.
I was following this tutorial: MINDSTORMS EV3 Support | Everything You Need | LEGO® Education
Here’s an image of what i got in the notification from balenaEtcher
Képernyőkép 2023-09-05 001607

Ive solved it by downloading an older version and i used a url instead of the downloaded file and it worked for some reason.

Hello,
Could it be the image you downloaded and was flashing didn’t download properly and was corrupted. Did you try downloading the image again and then flashing it? Just to rule out if it’s not the image that is causing the issues.

Hi
Yes, I redownloaded the image multiple times and it still didn’t work with the latest version.

Have you also tried unzipping the file before you flash it?