Screenly OSE + Balena + Wifi not connecting

I’m in a public school setting in the USA, and I’m following this tutorial to make a digital billboard with Screenly OSE.
I have successfully:

  • Flashed the BalenaOS disk image through BalenaCloud that includes Screenly and the wifi credentials
  • It boots to the Balena Cube logo, then hangs, the Raspberry Pi 3 B flashing the 4 lights, pause, 4 lights indicating no wifi connection.

So I put the SD in my PC and changed the wifi settings to my phone’s hotspot in case some ports at school were blocked, but I get the same problem and 4 lights.

The “resin-wifi-1” file is currently set for my phone’s hotspot with these settings:






I’m fairly new to this, but my students and I are determined to get our digital billboard working to show students walking through the hallways what our tech lab is up to!

Any ideas?

This configuration looks correct. Except maybe hidden=true. Is your phone access point hidden ?
Does your phone see a new client connecting ?
Do you have an Ethernet connection available for checking ?
If not, you can try downloading a development image and connect to the pi via the serial port with a cable like this one

I set the hidden to false, and same result, and the phone doesn’t show a client connected. Got a new message though, see below.
Tried with Ethernet and got the same new message on boot:

Do you see the device appearing on the dashboard when it is connected through Ethernet ?

I made a mistake, the ethernet port was not correctly connected (broken snap-in pin). After fixing that, I get the ASCII Balena on boot and I see it in the Balena dashboard. The pi is showing a generic login that is not accepting my Balena credentials.

The log on the dashboard shows this:

13.10.20 09:52:35 (-0400) Supervisor starting
13.10.20 09:52:39 (-0400) Applying configuration change {“SUPERVISOR_POLL_INTERVAL”:“900000”,“SUPERVISOR_DELTA_VERSION”:“3”}
13.10.20 09:52:39 (-0400) Applied configuration change {“SUPERVISOR_POLL_INTERVAL”:“900000”,“SUPERVISOR_DELTA_VERSION”:“3”}
13.10.20 09:52:40 (-0400) Creating network ‘default’
13.10.20 09:54:53 (-0400) Supervisor starting
13.10.20 09:54:55 (-0400) Applying configuration change {“SUPERVISOR_DELTA”:“1”}
13.10.20 09:54:55 (-0400) Applied configuration change {“SUPERVISOR_DELTA”:“1”}
13.10.20 10:08:50 (-0400) Supervisor starting
13.10.20 10:08:52 (-0400) Applying configuration change {“SUPERVISOR_PERSISTENT_LOGGING”:“true”}
13.10.20 10:08:52 (-0400) Applying boot config: {“disable_splash”:“1”,“dtoverlay”:[""],“dtparam”:[“i2c_arm=on”,“spi=on”,“audio=on”],“enable_uart”:“1”,“gpu_mem”:“16”}
13.10.20 10:08:52 (-0400) Applied configuration change {“SUPERVISOR_PERSISTENT_LOGGING”:“true”}
13.10.20 10:08:52 (-0400) Applied boot config: {“disable_splash”:“1”,“dtoverlay”:[""],“dtparam”:[“i2c_arm=on”,“spi=on”,“audio=on”],“enable_uart”:“1”,“gpu_mem”:“16”}
13.10.20 10:08:52 (-0400) Rebooting
13.10.20 10:09:59 (-0400) Supervisor starting

Hey there,

Thanks for contacting

I think what you are seeing there is the request login from tty1 which suggests that the Screenly services aren’t starting. I found this issue describing the same behaviour:

The suggested solution is to try using the master/dev branch of the project instead

Let me know if that helps


I flashed the production branch, and though the pi gives the 4 blinking lights cycle, it DOES show up in my balena dashboard, but as Inactive, as seen below. The screen is just stuck on the balena logo. I can’t seem to get it to have a status of “Online”.

Hey Mark, I wonder if your network is blocking any of the traffic between the device and balena cloud - since you’re in a school, maybe there are some restrictions in place? Do you have any other balena devices active on the same network, if not, maybe its worth creating a new application in the dashboard, adding a new device, downloading the image and flashing it to your device. We can then see if your device appears (online) on the dashboard, which would rule out any network restrictions getting in the way