WiFi Adapter doesnt work even though it is on the supported list

I run screenly-ose on the raspberry pi 3 and used a standalone installation before but wanted to switch to balena now. Unfortunately the WiFi adapter (RTL8192 chipset) is not compatible with balena since version 2.26.x. Screenly doesnt work on that version anymore, the wifi dongle works fine. In the newer versions, screenly works but the wifi dongle doesnt and it is really needed since the on board wifi doesnt have enough power.
First I tried compiling my own version of balena os, but it kept erroring out on Windows Subsystem for Linux.
Then I looked on the page of working wifi dongles and found the TP-Link Archer T2U nano (linked from “AC600”), looked up the chipset (RTL8812) and saw that the T2U plus uses the same chipset but has a big antenna. So I bought that. But it still doesnt wanna work (usb-devices shows “driver: none”).
Any other WiFi dongles I can try that are known to work with the Pi 3? Otherwise I might have to look into compiling it myself again but that makes updating kinda hard.
Thank you


Can you share the dmesg logs when you power up with the device connected? Perhaps there’s something in the logs that can help us figure what’s happening