Resin build invalid reference format - and Chrome crashes


I’m trying to build an image that a colleague created. When running resin build --deviceType intel-nuc --arch x86 I get (HTTP code 500) server error - invalid reference format: repository name must be lowercase – and it also causes my Chrome to crash. Sometimes it crashes the whole browser, sometimes only the Chrome Helper processes (and therefore all extensions).

I am running on macOS 10.13.3, while my colleague is running Linux (not sure which distribution, and he’s unavailable today).

Any ideas?

Hi there,
so if I understand correctly you are using the CLI to build your image. I’m not sure I understand how this is related with the Chrome browser. Do you mean that when running the cli commands, your browser crashes?

Exactly. When I run resin build... either just the Chrome Helper or the whole browser crashes. I have no idea why that might be. The crash occurs inside

One more data point: closing Chrome and setting the default browser to be Safari also results in a crash dialog, this time for Safari Web Content.

I’ve fixed the invalid reference format by using -n (the directory name where my repo was cloned was mixed-case). However, I’m still experiencing the weird Chrome crash. It seems that each time I run resin build some random Chrome process crashes, sometimes it might be the one that controls some tabs, other times the one that controls some extensions, then again it might be the main Chrome process. I realize that the resin CLI uses the browser for login (and that works fine) but I fail to see why it would use or interfere with the browser during a build .

Any idea what might be making the browser crash? It’s not just Chrome. If I close Chrome and set Safari as my default browser, I also get a crash dialog for Safari Web Content. It’s really annoying.

Hey @mario, that’s certainly strange, and not something we’ve ever heard of. Are there any further details you could provide which might help us debug this situation? Any extensions that might be interacting weirdly with the CLI for example?

Another thing that could be a problem is a build using too much memory which causes OSX to kill one or more chrome processes. Is high resource usage something you’ve noticed when this occurs?

High resource usage… not really, closing Chrome frees up quite a bit of RAM. Same thing with extensions. As I mentioned, this happens also with Chrome closed and using Safari as the default browser (and I have my Safari almost devoid of extensions). So the CLI shouldn’t be doing anything with the browser during build?

Can you tell us which exact version of the resin CLI you’re using?

This was happening with 7.0.3, just updated to 7.2.1 via npm -i -g resin-cli and it seems to have fixed the problem.