Build fails before it even starts

Hi All,

I am trying to convert a docker based product to Resin but as I push to resin I get he normal “starting build for x” and then immediately an exception is thrown:

$ git push resin combine-all:master
Counting objects: 1343, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (1175/1175), done.
Writing objects: 100% (1343/1343), 2.01 MiB | 0 bytes/s, done.
Total 1343 (delta 433), reused 153 (delta 78)

Starting build for user_name/app_name
remote: events.js:141
remote:       throw er; // Unhandled 'error' event
remote:       ^
remote: Error: read ECONNRESET
remote:   at exports._errnoException (util.js:837:11)
remote:   at Pipe.onread (net.js:544:26)
remote: error: hook declined to update refs/heads/master
 ! [remote rejected] combine-all -> master (hook declined)
error: failed to push some refs to ''

I have been able to build the project locally on a Raspberry Pi 2 running docker directly. So it doesn’t appear to be an issue with the Dockerfile itself.

I’ve also tried both master and master-arm. The error message doesn’t give much to go on so does anyone have suggestions for how I can debug what is going on here?


Hi Jon,

I just tried to push a test project and it works fine for me. Do you get this error every time?

Hey @petrosagg,

It works fine if I use a test project ( used the simple python project). It is just this specific project fails in the same manner every time I push it to Resin.

That’s very weird. Is the repo you’re trying to send on github? I’d like to try to push it on my account and see what is causing the error

It is a private, customer related github repo - So not one I can easily share unfortunately.

Can you give me your resin username and application name? Afterwards I can check my admin panel for errors. If this is also private, you can use the little question mark at the bottom right corner of the dashboard to have a private conversation with us

username: jmoss
application: WastePi

As I said earlier - I have been able to successfully push a “test” project to that application. So that is the only successful build there presently.

I am happy to start up a private conversation via the dashboard and trigger a build or similar if that is helpful?

Just to add some closure to the thread, we’ve followed up over intercom and resolved this issue, and also fixed a bug with weird filenames. Thanks @moose!

Yes - all good now. I just had some oddly encoded example files in my repo. @petrosagg was able to locate the issue and resolve it in short order. In fact he already had a fix in the pipeline for dpeloyment :smile:

Thanks @petrosagg! Much appreciated.

And in fact it got deployed a couple of hours ago. The fix is live!