Regarding DAC installation on balenaSound project


My name is Chris, and I worked the balenaSound project to give old hifi stereos bluetooth compatability. Great project and I loved working it. I also decided to
install a DAC as well because I enjoy audio fidelity. However it was here that I ran into some issues.

First and foremost I was able to work the problem. It goes as such; when installing the DAC there needs to be some config changes. It is specified that the
BALENA_HOST_CONFIG_dtoverlay = hifiberry-dac did not work for the IQ Audio DAC+ that I specc’ed for this project. Instead I needed to set the dtoverlay parameter to
iqaudio-dacplus which took some digging to find but I got it eventually.

This brings me to my actual point: I believe the balenaSound project should be updated to reflect differences in DAC devices and should include some type of blurb about how
different DAC devices may require a different parameter than the one specified. Below is a link covering the dtoverlay parameters for IQ Audio’s various DAC devices. I’m sure
there are more out there that have yet to be found. The aim of this thread is to provide discourse on this particular change and I invite all to discuss the implications,
good and bad, of such a change. Thank you for your time.

TL;DR I believe the balenaSound project should be updated to reflect differences in DAC devices.

IQ Audio Config Guide

Hey Chris, thanks for this post. I am happy to hear you had fun with balenaSound and were able to get the DAC working. I think its a great idea to document this in the balenaSound project, feel free to open an issue or, who knows even a PR :P, to so the project maintainer can chime in with some feedback and pointers.

@clevertanooki, this would be great.
I am using a Suptronics X400 board and have similar problems.
Do you know what the correct setting for that board might be?
I found this page from the Volumio project -

In Volumio my device uses the settings:

{"id":"st400-dac-amp","name":"ST400 Dac (PCM5122) - Amp","overlay":"iqaudio-dacplus","alsanum":"1","mixer":"Digital","modules":"","script":"","needsreboot":"yes"},

but that doesn’t seem to work.

Would love to get this working soon, I have a party at the weekend and need the tunes!

I have fixed this by also using iqaudio-dacplus in place of hifiberry-dac.
I have added a page to the project documentation to record these settings for different projects.