raspberry pi zero W won't show up

Hello everyone,
i’m new here and my goal is to build a multi-room system with balena. I’ve already successfully added a pi 4 over WiFi to balena cloud but now i’m struggling with adding my pi zero.
The zero starts booting but after around one minute it starts blinking 4 times (3 times short 1 long) and won’t show up in balena.

I have already tried:
-downloading the OS multiple times and double/tripple check my WiFi credentials
-using different SD-cards
-using different power adapters

Does anyone have any advice for me on how to proceed?
Thanks in advance and have a nice weekend :grin:

@Th3sAib0t welcome to the forums. Is there any chance you’re able to connect a monitor/TV to the Pi Zero and check the output on the screen? It’s also possible to achieve the same with a serial console cable in case you have one of those.

Also just to check, you wouldn’t be able to add a Pi Zero to a Pi 4 application, you could only add a Pi 4 to a Pi Zero application - is that what you’re doing or are they two separate apps? Also worth noting that you would have to download a separate OS version for each device type.

I hope this helps but come back to us if you need any more help!

Thx for your quick reply! Unfortunately i don’t have a mini HDMI-cable but i ordered one.
For the setup i followed this guide: Get started with Raspberry Pi
-i chose as default device type the pi zero
-i downloaded the correct version for each pi

Worked on pi 4 flawlessly, but not on pi zero…

I have now wasted my entire morning but finally the zero showed up :smile:.
I used my older WiFi router because i saw that the zero doesn’t support 5 GHz. But still i’m a bit confused beacause my wifi router is a Netgear Orbi rbk50 and both the 2.4 and the 5 GHz networks are activated (have also other devices that only support 2.4 GHz and work fine).

Is there an option to add the zero to my normal network?

I’d like to add I am have exactly the same problem…but as my router is also a Netgear Orbi rbk50 I wonder if the problem is with our routers… for the record I have…

  1. Created a pi zero/pi 1 application and added the pi (its the train sign application, using your guide.) Pi does not connect to my wifi.
  2. Same pi zero with a fresh raspbian/debian install connects to my network right away, so it is not the hardware
  3. Add a Pi3 to the application, it connects right away.
  4. I copied the working resin-wifi-01 file from the Pi3 sd card to the Pi Zero and tried again - and it still would not connect to wifi.
  5. Same card in rpi B+ with a usb wifi dongle, again does not connect to my wifi.

So I think we can say the problem has something to do with the config of the balena OS or how our routers deal with said config.
Are there any commands we can run on the offending devices to gain some insight into the problem ?

@Th3sAib0t well done getting it running. In combination what what @Spacer wrote (welcome to the forums, by the way!), I am wondering if it’s an issue where you guys are running both 2.4GHz and 5GHz networks together with the same SSID? I mean that alone doesn’t explain why it works fine under vanilla Debian. I have heard of similar issues before, but as another datapoint, I am running 2.4GHz and 5GHz WiFi here using the same SSID for both frequencies using Unifi access points and have no issues connecting Pi Zero devices.

If you’re able to get connected to the Pi Zero, either by connecting a monitor/keyboard/mouse, or via serial terminal, or even via using a wired ethernet adapter, there are definitely some things we can do to dig into why it’s not connecting. BalenaOS is using NetworkManager so we can use nmcli to do some debugging.

From a terminal connected to the host OS, nmcli d wifi list will perform a WiFi scan - it would be interesting to know if this scan shows the network you’re trying to connect to. For example if I run that scan here on a Pi Zero, I can see my SSID listed once on a 2.4GHz channel, but if I run that same command on a Pi 3B+ or balenaFin, I can see my SSID listed twice, once on a 2.4GHz channel and then again on a 5GHz one.

Then, if you want to force a connection, you can use nmcli d wifi connect <ssid> password <passkey>.

To view logs you can use journalctl -u NetworkManager.

Perhaps if you’re able to grab logs of a failed connection attempt it may reveal something that will help us further narrow down what the cause could be here. I hope this helps!

Thanks for the reply - in anticipation of running the test your recommend I flashed a new image, however I used Development instead of production. Stuck in the pi and left it for a while (be patient), and it has connected to both the wifi and my application. @Th3sAib0t maybe you could give it a try and see what happens ?

Excuse me for my very late reply, I had to work a lot… Actually my my colleague has managed to connect the zero to the WiFi. He change the SSID and the PW from the old router to the credentials of my new router. Then he connected the pi zero to old one and after the zero appeared in the balena cloud, he had no problems to also connect to the new router. I hope I find some time this weekend to try chrisys idea also.