Raspberry Pi Zero 4 Blinks

I setup an app and downloaded the development image for Raspberry Pi Zero W on the Balena Cloud UI and flashed it using Balena Etcher to an 8G Micro SD card. I have not made any modifications to it with the CLI. After some OK led activity it then blinks 4 times. I have tried this on open balena as well and the same issue.

I am using:


Seems like if I add the WiFi information it “works” (not blinking green anymore) but won’t register with open balena at this point. Has anyone encountered this? It’s not a time issue, been about 20 minutes and still no device registrations when I run balena devices

OK, can you please try to (re)download a WiFi configured image from your RPi0 balenaCloud app and flash that again. If the device doesn’t appear in the dashboard after a few minutes, check your router to see if it has been assigned an IP. You can ssh into the development OS variable without a password and inspect the configuration from there… If it doesn’t get assigned an IP, connect a screen/keyboard to the RPi and see what is being printed to the console.

You also mention openBalena, which is entirely different from balenaCloud. This will require some additional configuration of the OS, including certificate injection, etc.

Hi, I see that you are using a development image. Does the device appear in the list when you run sudo balena scan? You should be able to ssh into the device hostOS using the balena ssh <device_local_IP_address> command.

Once you are able to connect to your device via local IP address, you should be able to check the supervisor logs from the hostOS to see if there are errors encountered in attempting to connect to your openbalena setup.

Well this is concerning haha. I just did my steps very carefully documenting it (same steps i’ve been doing over and over) and now it works. I am seeing the device on openBalena and on the balena cloud. Unfortunately I can’t be more help as to what was going on but if it shows up again i’ll add more information here.

Thanks for your help!