Raspberry Pi 3 stuck on boot splash screen

I pushed the normal BalenaDash to my Rp3 but when power it up im stuck on the boot up splash screen. On browser dashboard it shows the rp3 as “Online”, I can also access it via its IP address and change for example the displayed website (although on my monitor the splash screen also doesn’t change). What did I do wrong?


What do you see on the dashboard ?
Can you see if the device has downloaded the application release ?

Also all services are running

Have you set BALENA_HOST_CONFIG_gpu_mem to 128 ?
What are the logs of the kiosk container ?
If you open a terminal in the kiosk container, what do you see if you type ps aux ?

I made a new application with the balenadash project from the start (I didn’t start with dash in the first one) and now it works! I didn’t set the BALENA_HOST_CONFIG_gpu_mem to 128 in the first one, too.

Now I’ve got a new problem:
Although I set config_mode to 1 everywhere, the kiosk browser is still in fullscreen…

If you’re talking about this CONFIG_MODE: https://github.com/balenalabs/balena-dash/pull/74 , it has to be uppercase.

oh I failed to mention that it is uppercase

Where have you set it ?

Environment variables, service variables and device variables. It’s 1 everywhere.

You need to set it in service variables for the kiosk service.
You should see if it is enabled in the kiosk container logs: https://github.com/balenalabs/balena-dash/blob/master/kiosk/launch.sh#L22-L27

In the logs it doesn’t show anything about config mode (nor enabled/disabled)

Can you please provide the kiosk service logs ?

I removed the service variables now because when I added SHOW_CURSOR kiosk would crash. When I change SCHOW_CURSOR in Device variables (screenshot) to 1, it works. CONFG_MODE still doesn’t work.

20.10.20 18:40:29 (+0200) kiosk Disabling cursor
20.10.20 18:40:29 (+0200) kiosk 2020/10/20 16:40:29 Command is ‘cog’
20.10.20 18:40:30 (+0200) kiosk 2020/10/20 16:40:30 Starting listening on port 8080
20.10.20 18:40:35 (+0200) kiosk Connecting to localhost:8080 (I-removed)
20.10.20 18:40:35 (+0200) kiosk 2020/10/20 16:40:35 Launch page with desiredURL = ‘https://meet.ur.de/pdajourfixe’. Slack: false
20.10.20 18:40:35 (+0200) kiosk 2020/10/20 16:40:35 Redirecting to home page
20.10.20 18:40:35 (+0200) kiosk 2020/10/20 16:40:35 Running ‘cog https://meet.ur.de/pdajourfixe
20.10.20 18:40:35 (+0200) kiosk 2020/10/20 16:40:35 Responded with home page
20.10.20 18:40:35 (+0200) kiosk saving to ‘index.html’
index.html 100% |********************************| 2122 0:00:00 ETA
20.10.20 18:40:35 (+0200) kiosk ‘index.html’ saved

Hey @AlexW00, currently if you’re using balenaDash on a Pi 3 CONFIG_MODE is not supported. However, it is due to be added any day now. If you would like to try the new version which does support it on this device, you can push the code from this alternate branch on the GitHub repo: https://github.com/balenalabs/balena-dash/tree/v1.0