Pi 4 Stuck on Splash Screen

So I was trying to use balenaDash to display google photo albums by following the guides listed below. I was able to get the Pi to join the dashboard and was able to install the balena-cli tool and pushed the balenaDash Project up to the Pi successfully. Pi downloaded the pushed balenaDash and showed a pumpkin in the CLI like it should. I created an environment variable and restarted a couple times and BalenaOS never goes past the splash screen. I tried the variables (GALLERY_URL) with a Google Photos album with no luck, stuck on splash screen. Then I tried (WPE_URL) with a YouTube video and still nothing, stuck on splash screen. I am using the onboard MicroHDMI, I don’t know if this is some of the issues.

Any help? I can enable remote access, I’m new to the forums and to the Pi.

Thanks!!

Hi,
Can you share with us what OS versions are you using and the exact command that you used to push the new release to it?
As you suggested, it would be helpful if you could grant us support access and send us the dashboard url of the device so that we can take a closer look on the configuration and the device itself.

Kind regards,
Thodoris

HOST OS VERSION [balenaOS 2.44.0+rev3]

SUPERVISOR VERSION [10.3.7]

Support Access:
https://dashboard.balena-cloud.com/devices/26f7f8192e8c8235ca95bd6355df78c4/summary

C:>cd projects

C:\projects>cd simple-server-python-master

C:\projects\simple-server-python-master>dir
Volume in drive C has no label.
Volume Serial Number is 1838-17F0

Directory of C:\projects\simple-server-python-master

10/30/2019 10:51 AM .
10/30/2019 10:51 AM …
10/30/2019 10:50 AM 5 .dockerignore
10/30/2019 10:50 AM 922 Dockerfile.template
10/30/2019 10:51 AM img
10/30/2019 10:50 AM 1,457 README.md
10/30/2019 10:50 AM 13 requirements.txt
10/30/2019 10:51 AM src
4 File(s) 2,397 bytes
4 Dir(s) 893,736,878,080 bytes free

C:\projects\simple-server-python-master>balena push RovenstineSlide
[Info] Starting build for RovenstineSlide, user dennis_casey
[Info] Dashboard link: dashboard.balena-cloud.com/apps/1535523/devices
[Info] Building on arm03
[Info] Pulling previous images for caching purposes…
[Success] Successfully pulled cache images

I think I provided the correct dashboard link. Please let me know if it is wrong.

Hi again,
After doing some research on this it seems that the balenaDash project currently has some issues running on an RPi4.
In more details it seems that the WPE Webkit version that balenaDash is using, does not work on the RPi4 because of the new firmware no longer supporting the closed source gl drivers.
You can find more details about the WPE RPi4 issue in the following GitHub repo issue:

The best place to track progress on when this gets fixed in a new balenaDash version is on this GitHub issue:

We will let you know once a new release with a fix for this is out.

Kind regards,
Thodoris

Does that also include the GALLERY_URL variables?

No. I can only see the WPE_URL environment variable being set on the application that you shared.
On the other hand, given the above, it sounds like the issue isn’t caused by a bad configuration but needs to be fixed in the balenaDash project itself.

Okay, I was using GALLERY_URL before and that didn’t work either. Currently switching to Pi 3 to see if that works. Will be in dashboard shortly, burning SD card and booting.

I have the Pi 3 with WPE_URL setup, still isn’t working. Can you take a look at that?

https://dashboard.balena-cloud.com/apps/1535523/devices

Hi,
I saw that the RPI3 device that you provisioned is a 64bit one, and it seems that WPE isn’t able to run on 64bit OSes at the moment.
Since https://dashboard.balena-cloud.com/apps/1535523 is an app targeting aarch64 as the minimum compilation target you can’t add non 64bit devices in it, and as a results only the 64bit variant of the RPI3 images show in the OS selector of the “Add device” modal.

Can you create a new RPi3 application (not 64bit), push the balenaDash project in it and provision a RPi3 with a non-64bit image (for example 2.43.0+rev1)?