RaspberrPi Zero 2W not showing up in balena cloud dashboard

Hello balena friends!

I’m having some issues in making a Raspberry Pi Zero 2W appearing in my balena cloud dashboard. I had freshly burnt balena os version v2.105.21 and after several minutes the device was still not showing up in the dashboard, so I decided to connect an external monitor to the device, and it was stuck on this screen here

Although this is my first using a RPiZero2W, I have used balena cloud several times and never had such an issue!
Would you guys any idea of what it could be?


Hey @saveriogzz welcome to the forums.

As I mentioned in the other thread, could you confirm the method you’re using to flash your SD card and if you’re using the ‘Flash’ button in the dashboard to automatically open Etcher, could you instead try downloading the balenaOS image and selecting it manually to flash in Etcher and let us know if that makes a difference?

Hey @chrisys ! Yes, I confirm that I was using the method that automatically opened Etcher. I just tried to download the img first and then flashing it, but the result is the same unfortunately.

Just to tie up loose ends: thanks to our lovely team, this should now be resolved in the latest 1.18.4 version of Etcher :+1: