Quactel UC20G - not connecting - Resin 2.7.5

Can you push an update of your app and make sure you do not run NetworkManager and ModemManager in your container?

Hi @floion,

yes, just about to do it. I have experimented at the moment by using strech instead of jessie. I am about to push newest image without NetworkManager nor ModemManager. Will see how it goes. If not I will downgrade to jessie back again.

At the moment I can see Cellular ip. I guess you have changed something.

@floion I had to hard reset the device.

Kind regards,
llap

Is this a test device? Or is it in production?
If it is a test device, I would like to do some changes on it to test something out

Go ahead. It is not yet production.

Kind regards,
llap

I will mention that my touch screen is not working at the moment.

@floion I used to have problem with the modem and ModemManager.

It was solved by installing ModemManager in container. The problem was that every time application restarted or was updated or initial image pull - disconnected modem.

When I installed MM but not NM inside container it was working correctly.

LL

Let’s take this opportunity and get it working without having to install ModemManager and NetworkManager in the user container. I don’t like that approach. So let me look in the following days on that machine of yours please

That sounds good. I will leave the device on for you. Next week I will however need to deploy it so it will not be possible to share it for rebooting etc.

Regards,
LL

@floion how should we proceed with this case? Will it be possible to fix the issue? Unfortunately I have touch screen so having this udev trigger is important for me to have it usable after update.

Regards,
LL

I am still looking into this. And will get back to you once I find something. Maybe leave the board for debug/hacking as much as you can?

As a last resort, will it be possible for you to use the older working OS until this gets solved? If this then gets solved, you could update the host OS to the version that has the problem fixed

Sure, I will leave it until the end of the week for you. I have extended support access.

Yes, that what I was going to do. After the weekend I will downgrade to 2.2.0 and deploy it. Then maybe upgrade it later someday. Wish it was 2.7.5 that is remotely upgradable.

Regards,
LL

@imrehg where are we with resinHUP for the Intel NUC?

That does not sound too good, I have a modem from the same manufacturer. Is this a problem with all modems or only with this particular type? I think it’s too early to switch to 2.7.5

@lapacz, It doesn’t seem to be the case for all modems. I have v2.7.5 with 3 different Huawei modems and 1 Sierra Wirelss modem. It looks to maybe only be linked to the Quectel modems.

Hey @lapacz , It turns out that the issue with Quectel modems had to do with upgrading the RPI3 kernel to 4.9. It seems that some changes in this kernel version broke libqmi which all QMI (qualcom) based modems depend on. We have since patched libqmi and I now have my Quectel modem working perfectly with a build of resinOS 2.8.1 . We should be releasing this version in the coming week.

2 Likes

Hi, any news on the release of 2.8.1? I’m trying to get a Quectel UC20 working with 2.7.8.

Have you tried 2.9.6? I have not yet, but maybe it works?

No, the latest for RPI3 is 2.7.8. I noticed that the 2.9.6 is available when selecting the Intel NUC.
Also I think the qcserial kernel module need to be loaded at boot.

hey @rytterlund, we should be releasing 2.9.6 today, we had a few issues and features to add, so it took a bit longer than expected.

Quactel UC20G works fine with 2.9.6 / intel NUC. Thanks guys.