Quactel UC20G - not connecting - Resin 2.7.5



I was looking forward to upgrade to 2.7.5 version of resin. But I have problem with cellular modem.

I have modem Quactel UC20G on intel-nuc machine using resin/intel-nuc-debian:jessie-20171031 image. With 2.2.0 - my modem worked perfectly. Now it says in logs it can not find any plugins that could handle this device. Could you please help?

journalctrl -u ModemManager

journalctrl -u NetworkManager

Part of dmesg

Thanks for help. If required I could grant access to my device.

Kind regards,


Hey, I don’t know of any reason the plugins would have been removed, I’ve pinged our device team to investigate this and they should get back to you


If you can enable support access and share the dashboard link as well then that should help the devices team investigate this @llap



thanks for quick response. I have granted access. Sending as private message more details

Kind Regards,


And the CPU usage because of Network Manager is pretty high


have you changed also your application when you switched from 2.2.0 to 2.7.5?
Also, are you using NetworkManager in your container?


Hi, are you currently using the board and rebooting it?


Can you push an update of your app and make sure you do not run NetworkManager and ModemManager in your container?


Hi @floion,

yes, just about to do it. I have experimented at the moment by using strech instead of jessie. I am about to push newest image without NetworkManager nor ModemManager. Will see how it goes. If not I will downgrade to jessie back again.

At the moment I can see Cellular ip. I guess you have changed something.

@floion I had to hard reset the device.

Kind regards,


Is this a test device? Or is it in production?
If it is a test device, I would like to do some changes on it to test something out


Go ahead. It is not yet production.

Kind regards,


I will mention that my touch screen is not working at the moment.


@floion I used to have problem with the modem and ModemManager.

It was solved by installing ModemManager in container. The problem was that every time application restarted or was updated or initial image pull - disconnected modem.

When I installed MM but not NM inside container it was working correctly.



Let’s take this opportunity and get it working without having to install ModemManager and NetworkManager in the user container. I don’t like that approach. So let me look in the following days on that machine of yours please


That sounds good. I will leave the device on for you. Next week I will however need to deploy it so it will not be possible to share it for rebooting etc.



@floion how should we proceed with this case? Will it be possible to fix the issue? Unfortunately I have touch screen so having this udev trigger is important for me to have it usable after update.



I am still looking into this. And will get back to you once I find something. Maybe leave the board for debug/hacking as much as you can?

As a last resort, will it be possible for you to use the older working OS until this gets solved? If this then gets solved, you could update the host OS to the version that has the problem fixed


Sure, I will leave it until the end of the week for you. I have extended support access.

Yes, that what I was going to do. After the weekend I will downgrade to 2.2.0 and deploy it. Then maybe upgrade it later someday. Wish it was 2.7.5 that is remotely upgradable.



@imrehg where are we with resinHUP for the Intel NUC?


That does not sound too good, I have a modem from the same manufacturer. Is this a problem with all modems or only with this particular type? I think it’s too early to switch to 2.7.5