Pushing OS's to Applications

I’m new to this and I’ve started by following the BalenaSound guide. It was a good introduction to this system and things went well. But what about pushing operating systems like raspbian or volumio. I want to push volumio to my application but i don’t think its possible to push a .img file. Even the entire GitHub folder comes up missing the Docker file. I don’t know where to go from here, I’ve tried adding ‘dud’ docker files just to see if it would just work, no luck. Again, I’m new to BalenaCloud but would it be better to just flash the .img to an SD card or is there anyway to do it through BalenaCloud?

Hi, a good place to start is to follow one of our “Get Started” guides, for example https://www.balena.io/docs/learn/getting-started/raspberrypi3/nodejs/.

Once you understand the concepts, there is whole library of available images you can use at https://www.balena.io/docs/reference/base-images/base-images/, including raspbian based images (https://hub.docker.com/r/balenalib/rpi-raspbian).

Regarding volumio, we don’t have production images, but there is something in the labs you might want to check out https://github.com/balena-io-playground/balena-Volumio2.

No luck with the balena volumio2 (still shows no docker file) but the raspbian link and base images link were useful. Thanks for the help!

Hi, could you be a bit more descriptive with the “no docker file” error? Note that if you are using “balena push” you can use the --dockerfile argument to specify the exact Dockerfile you want it to use.

Directory of C:\Raspberry Projects\Volumio\balena-Volumio2-master

04/03/2020 12:04 PM .
04/03/2020 12:04 PM …
04/03/2020 12:03 PM 724 .eslintrc
04/03/2020 12:03 PM 634 .gitignore
04/03/2020 12:03 PM 105 .gitmodules
04/03/2020 12:03 PM app
04/03/2020 12:03 PM 248 discoveryTest.js
04/03/2020 12:04 PM http
04/03/2020 12:03 PM 383 index.js
04/03/2020 12:03 PM 1,398 package.json
04/03/2020 12:03 PM 5,283 README.md
7 File(s) 8,775 bytes
4 Dir(s) 117,388,570,624 bytes free

C:\Raspberry Projects\Volumio\balena-Volumio2-master>balena push Volumio
[Info] Starting build for Volumio, user g_tropical19
[Info] Dashboard link: https://dashboard.balena-cloud.com/apps/1625100/devices
[Error] Could not detect project type: Service main: Could not find a Dockerfile for this service
[Error] Not deploying release.
Remote build failed

Additional information may be available by setting a DEBUG=1 environment
variable: “set DEBUG=1” on a Windows command prompt, “$env:DEBUG = 1” on
powershell, or “export DEBUG=1” on Linux or macOS.

If you need help, don’t hesitate in contacting our support forums at
https://forums.balena.io

For CLI bug reports or feature requests, have a look at the GitHub issues or
create a new one at: https://github.com/balena-io/balena-cli/issues/

i believe the issue is that there is no docker file at all

You’re right. I blindly assumed there would be one. Let me ask around see if someone in the team has experience with Volumio and I’ll come back to you.

Thanks you, I appreciate it greatly!

Hi, a couple of my colleagues have unsuccessfully tried in the past to run Volumio in BalenaOS but unfortunately the distribution is tightly coupled to the hardware to optimize the audio playback. It may be worth to re-try with newer versions though. Let us know if you make any progress with it.

Will do, thank you.