Problems Booting Raspberry 4 from balenaOS generated from balenaCloud dashboard

Hi there,

I’ve been developing with the balenaOS development image on a raspberry pi 4 successfully so far.

I’m now trying to scale the application with a proof of concept fleet with balenaCloud (Free starter mode), so as I understand it need to use image generated from my dashboard in order to preload with the various bits (I’m guessing some certificates & some scripts to fetch updates from a remote endpoint).

I’ve followed the steps as instructed but I cannot get the pi4 to boot.

  • No wifi connectivity.
  • No cabled ethernet connectivity (just orange connection light)
  • No HDMI screen output whatsoever.
  • Red power light on constant.
  • Green ACT light flashes intermittently/randomly as you might expect during normal operation, no obvious pattern.

Things I’ve checked:

  • I can read the SD card on my laptop no problem.
  • I’ve tried the same image on another SD card (both 16GB)
  • I’ve tried a different(identical) RPi4.
  • I’ve reverted to the generic image from the public download link. Works fine no problem.
  • I’ve deleted and recreated a new application.
  • Tried recommended 2.58.6 and 2.56.0 images.
  • Leaving it overnight.
  • I’m using balena etcher fro flashing but also tried gparted to first wipe the sd card. No change.

Very grateful for any suggestions of subsequent steps to get me up and running.


Hello @henryp welcome to our forums!

Just to confirm, you’ve been working with an unmanaged balenaOS image so far, right? By unmanaged, I mean one you download directly from our balenaOS website or GH repo, as oposed from one downloaded from balenaCloud.

You are correct, the image you download from balenaCloud is pre-configured to be able to communicate with our infrastructure. Apart from that, is the same balenaOS you download from the website, so there shouldn’t be any issues.
A few things you sould consider:

  • Even if you use balenaCloud, you can select a “Development” image for testing the Dashboard and its features. Development means you can develop locally as well as on through the dashboard.
  • After connecting the SD card with the balenaCloud generated image, do you ever see the device show up on the dashboard (under “Devices”)?


Hi there,

Yeah that sounds right, previously using an unmanaged image.

I should have said that I also have tried the devleopment image from the BalenaCloud dowload link.

Knowing that the image is essentially the same, is there a particular file/folder where any ‘managed’ elements could be found - I’m tempted to try merging that into a working image.

I never get the device to show up on the dashboard and in fact the device never attempts a connection to a network.



We have a list of networking requirements you can check here just to be sure (if you haven’t already).

Regardless of that, is there anything (that you know of) that could block the device’s connection? A firewall rejecting the device or the VPN for example.

Hmm, I’ll check networking but there’s something more amiss.

My unmanaged image is expanding out the resin-data partition to +13gb (as expected) but the managed images aren’t [on forensic inspection of the two sd cards after having spent some time powered up in the device]- it’s really failing to boot at all.

I’m thinking of doing a diff on the (mounted contents of the) two images to work out what’s going on.

Hi there, can you boot up an unmanaged image (dev.) variant and connect to it via SSH?

If so, os-config command on the host OS will allow it to “become” managed.

You’ll need to generate config.json and use that as a parameter to os-config. This should hopefully reveal where the issue is…

Hi @ab77,

I can certainly ssh into the unmanaged image variant. I like the sound of this, confidence in the idea of ‘upgrading’ an unmanged but funtioning device to become managed.

I’ll follow the steps and get back to you.


Update: v2.51.1+rev1 is in and working. Later versions (2.56.0 and 2.58.6) not.

Once in and connected with OS v2.51.1 tried upgrading from the dashboard.

Appears to have taken the thing offline again.

So just to confirm, you are configuring an unmanaged balenaOS v2.51.1+rev1 image downloaded from and it appears in the dashboard.

You then upgrade from the dashboard to either 2.56.0 or 2.58.6 and the device never comes back after the upgrade?

HI @ab77,

Sorry for the confusion, as a last attempt I actually used the managed image but on v2.51.1+rev1 and that almost immediately showed up in the dashboard as a connected device.

From there I attempted to upgrade the OS via the dashboard and the device went offline. In the dashboard this was shown as heartbeat only, but I would say this was an optimistic assessment as my router showed the device to be disconnected from the local network s no way any kind of heartbeat could be felt.

I realise that these pi4s may have never had their eeprom updated from time of purchase so I’m installing raspberry pi OS, and performing all the updates to see if this is the issue.

This could also be a faulty SD card/media. Do you happen to have another card you can try? Also, if you could plug a screen+keyboard into the device and watch it boot (press escape to get rid off the splash screen) to see where it’s getting stuck…

I’ve got two SD cards, both 16gb, class 10, decent quality, I’ve flipped between 2.56/2,58 and 2.51 on both and only 2.51 is working.

I’ve tried plugging in a monitor via the hdmi and when on 2.56/2.58 there is nothing shown to the screen whatsoever. Pitch black.

Very odd. Can you try downloading this, configuring it with your sshKeys and see if that boots unmanaged?

@ab77 sorry for the delayed response.

Just having no luck with any versions other than 2.51.1. The device isn’t booting, the partitions are not expanding out, HDMI shows a blank screen though some output (white characters on a black background) has been observed for the briefest of moments sporadically while powered on (not long enough to read).

I am taking delivery of some new top spec SD cards this week and will try with them for the removal of doubt but I’m inclined to say there is no issue with the one’s I have in use.

Very odd indeed. For now 2.51.1 is working for me and will do while I continue development.

Hi Henry,

Sorry to hear you are still having issues. Please let us know how the new SD cards work for you. Another thing you can try to debug this issue is enable uart on config.txt in the SD card and try to see if you get any output from the console when trying to boot v2.56. Here are some instructions on how to do that

Also, are you getting this issue with multiple PI4? Or just one?


Hi Felipe,

Thanks for the link, I’ll have a go at connecting with a terminal.

I have two pi4 model b 8GB, same behaviour on both devices and with across different SD cards.


I’m also experiencing a weird booting problem with my raspberry pi 4 that could be related:
When trying to boot balenaOS 2.56 or 2.58 on my raspberry pi 4 with a keyboard attached, the device will not boot. This happens both with a fresh image and when upgrading from the dashboard. I’ve got an HDMI monitor connected that turns the backlight on and off in a loop. This is strange as it works on 2.51.1 and below. When plugging out the keyboard (Apple USB Wired Keyboard) everything the pi boots fine :thinking:

What sort of power supply are you powering this up with?

5V 3A => 15W, so I do not think that this could be the problem. I’ve also never seen the lightning bolt that would indicate an under-voltage. Booting the latest Raspbian also works with the keyboard plugged in.

Thank you, we’ll have to try and reproduce this and figure out what is causing this issue in balenaOS > 2.51.1.