Balena OS just won't boot

I’m trying to run v2.53.12+rev1 on an Rpi4b 8gb using Wifi+Ethernet.
Flashed image file onto a 128gb sd card (tried using both Etcher and Raspberry Pi Imager)
I’ve successfully used Raspbian on my pi with this sd card.
When turning on the pi, my monitor flashes between off and black.
When trying to open fresh image file downloaded directly from Balena dashboard using Windows Explorer, it returns “The disc image file is corrupted” - not sure if this is normal.
Opened the sd card in Explorer after being flashed, everything looks regular but I’m pretty new to this.

Not really sure what other information to give, again, I’m new to this.
My best guess is that for some reason the Balena dashboard is providing me with faulty image files.
Any help would be appreciated, if you need any more information I’ll be happy to give it.

Hi, can you try with different sd card and see if the problem persists?

I tried using a 32gb microSD and the problem still persists.

Hi @ienjoyhorses,

I have a few questions that will help us narrow down the root cause.

  • Are you downloading a production or development image?
  • Could you try downloading an un-managed image directly from our OS website?
  • Have you pushed any code to the application you’re trying to connect? If you did, I’d also suggest creating a new blank application and trying to download the image again.

Welcome to our forums btw!

I have tried using both production and development images, also I tried a different version of the OS, neither changed the outcome.
I haven’t pushed any code, I’m just trying to install the OS and then push code.
The un-managed image yields no differences - tried it on both sd cards.


This is indeed strange. I’ve flashed a device recently, downloaded from the dashboard. So it’s most likely not an issue with the images coming from the balenaCloud (plus we’d have a bunch of other people also complain if we had an outage - but I just checked and that doesn’t seem to be the case)

Let’s try and debug this some more -

  • If windows opens up any pop ups, can you please ignore them
  • can you upload a screenshot of the Flashing Complete dialog box that happens after Etcher is done flashing.
  • Please make sure that there aren’t any other stray devices that are being flashed - and you are plugging in a different device in the Pi (has happened with me before :sweat_smile:)
  • would you have a serial cable? The device logs boot output to the serial console on a development image of balenaOS. If indeed there is some issue, we could see it on a serial console that you can open from your Windows using an application like PuTTy. If you have trouble with how to wire it up, please let me know and I can walk you through it