Problems Booting Raspberry 4 from balenaOS generated from balenaCloud dashboard

Hi Steffen, does this happen only on first boot or also once you plug the keyboard into a device again that has booted successfully before ?

Are you able to try this on v2.58.6?

This both happens on first boot as well as when restarting a device that has already booted. I’ve tried this on 2.56.0+rev1 and 2.58.6+rev1. As these are the only versions available on the dashboard I omitted the last digit above :sweat_smile:

Hey, can you try and connect serial cable and capture the output of the serial port when booting with and without keyboard? If there is no output in the serial, can you check whether there is a splash screen in the HDMI monitor? We couldn’t reproduce any of the issues unfortunately, and we will attempt to reproduce them again and investigate why this might be happening.

With the default config in balenaOS disable_splash is set as far as I know. I’ll disable this and check if I see a splash screen.
I will try to get the Pi connected to a USB serial adapter (never did that with a Pi before) and let you know what I find out :+1:

Sounds good, it will be interesting to know what serial port output you get with and without the keyboard attached.

Maybe this helps :smile:

Without the keyboard attached the device boots just fine:

When the device is booted, the Keyboard seems to take about 5 attempts until it is actually connected. But this behavior is actually the same on 2.51.1.

This is the output on 2.51.1 when the keyboard is attached. The Pi does not seem to initialize the USB controller and therefore the problem maybe does not appear?

Just as a quick side node: I’m only using this setup for development. In production this specific keyboard will not be attached to the pi, so there won’t be any problem (for me).

Hello @steffend

I’ve opened an issue on GitHub ( so that you can track progress on this.

It looks like you are using an Apple keyboard - does this problem still occur if you use different keyboards?

This seems to be specific to this keyboard (Apple MB110D/B with built-in USB Hub), I could not reproduce it with another USB keyboard I have.

Hi there,

@steffend glad you were able to resolve this your end.

From my side, I still absolutely cannot get most recent versions of BalenaOS to boot up on my raspberry pi 4s.

This is from a fresh flash onto new SD cards. I really cannot identify what I am doing wrong but evidently something because it doesn’t look like many others are having issues.


Hi Henry, it seems we had a couple of issues mixed in this same thread and that makes the conversation hard to follow.

Some things that you could check:

  1. I assume that the EEPROM firmware is unchanged and you are booting v2.51 and newer with the same firmware. It would be nice to confirm though.
  2. Then we will need you to plug an USB serial to your device and see what comes up when booting a non-working version.
  3. If there’s nothing, please try to modify a the BalenaOS image in the SD card and change the config.txt file in the resin-boot partition to remove the disable_splash=1 variable. Then plug in an HDMI monitor and see if there is anything on the screen.
  4. If there’s nothing, please report the LED blinkins patterns (see

On one pi I installed raspian and followed the steps in order to update the EEPROM firmware but this didn’t change anything.

I’ve a usb to serial cable on order so I’ll report back once that’s plugged in.

What mystifies me is how this is literally at boot from a cleanly flashed SD - so there’s really not much to eliminate in terms of what I’m doing differently.

There’s no LED pattern.

Hi @steffend you can check with the new version v2.65.0+rev1. It might take a bit longer to boot with that keyboard attached but should eventually boot after the usb timeouts expire. Was seeing a similar behavior with an arduino uno attached to the usb and that one is solved in 2.65.0.

Works for me! Exactly as you described: it takes a little longer, but it boots.
Thank you :smiley: