Problem on Linux

I just installed Balena Etcher 1.5.100 on Linux Mint 20.1 x86_64
It worked perfectly flashing a SD card, but now whenever I click an internet shortcut on my desktop, Balena starts up and wants to use it.

In linux this is a .desktop file.

In my settings the default app for this type of file is Firefox, but still Balena wants to use it.

How can I change this?

Hi - this seems to be an issue with xdg settings - and not etcher or Electron - and we’ve had someone report this before. Can you check the workaround mentioned on this issue - Missing parameter in set_url_scheme_handler_gnome3? (#180) · Issues · xdg / xdg-utils · GitLab . Please let us know if this works for you

That was exactly my issue and that trick solved it.
I did this: " sudo vi $(which xdg-settings) "
And then afterwards this: " xdg-mime default firefox.desktop text/html "
In my xdg-settings file it was line 1194. “set_browser_mime “$2” || return”

Thank you for the advice and solution, much appreciated. :wink: :+1:

Glad you got it to work Joe! Thanks for sharing the steps that you followed, that certainly will be useful for others!