Balena will not install/open on t450 running Fedora 33

I dont know why but now i cannot open balena on my laptop t450 running fedora 33. It downloads the option “Download for Linux x64”, it downloads, and then when i click on the file AppImage in the GUI or the CLI using xdg-open, it just brings up a window saying “Achive not supported” WTF?!? I’ve been able to utilize balena-etcher-electron before on this machine, yet for some reason, it is now not working. What gives here??? Very frustrating dealing with these issues that shjould be very easy tasks ona computer have now become a major pain the butt. Not fun at all. Please help??

That’s strange - especially if this worked earlier.

  • Can you confirm that your OS is indeed a 64 bit one?
  • Can you share a screenshot of the dialog? Do you see any additional logs when you run this from the CLI
  • Can you also try running it directly from the cli, instead of xdg-open. On my Ubuntu machine, I can simply run sudo ./balenaEtcher-1.5.109-x64.AppImage and it opens fine.

That fixed it. Thank you so much. You’re a lifesaver.

samuel Gearhart

You solved my problem before but now I’m having the same [REDACTED] problem with my raspberry pi 400. Ive downloaded both linux versions of balena, 32 and 64, yet neither one will work when I do your "sudo ./balenaEtcher-1.5.116-x64.AppImage and still nothing. This is absolutelyn f#@#$king ridiculous. It’s not your fault but i don’t understand why I keep messing with Linux??? It seems that every godamn thing is a huge research project and hal the time [REDACTED] does NOT work!!! I am extremely angry right now because I remember being in college anf mac windows all of it was so much easier to work with. Again, I don’t knw why i keep [REDACTED] with Linux and I can SO see why it never caught on with the average moron.


SAm Gearhart

Linux is much more difficult to work with for an average user, the tradeoff is in the transparency of the open-source code. You are certainly not alone, and many users do simply go back to Windows or Mac because they “just work”.

With that said, what is the exact error you receive when attempting to launch it on the Pi 400? Is it a permissions issue? File not found? Incompatible architecture? Applications starts but then crashes?

I’ll need more information, please include any logs, and a screenshot would be helpful as well.