piHole webinterface not reachable

Hi there,

i just installed a Raspberry pi 3 b+ with piHole in the Balena Cloud. I followed this tutorial:

Sadly, i am not able to access the Webinterface of the piHole Service.

This site can’t be reached

192.168.188.114 refused to connect.

Try:

ERR_CONNECTION_REFUSED

The Pihole seems to work in general.
Any Ideas?

Thanks and best regards

Hi,
Can you share your device uuid with us and enable support access for it? Then we can take a look at the device.
Best regards,

1 Like

I enabled the Support Access.

UUID: b8473b3

Hi,

Are you trying to use this with the TFT attached at all? I have just spun up the project on a device here and I see it working. I noticed your pihole service dies after trying to run the 30-checktft service so I am wondering if this could be related.

There is no TFT attached to the Pi. Just a Power Cord. Is there a way to run it without a TFT attached?

I am testing with just a power cord also - in the device actions, could you try purging the device’ data as this will basically reset the stored config for pihole and let it do it’s initial config again. It’s a long shot, but it rules out bad config.

I just purged the data, result is still the same.

Perhaps a long-shot question, but are you using Windows (as opposed to Linux or macOS) as the development machine? I mean the machine where you run git or balena push. The reason for the question is that in another investigation, it turned out that the check-tft script got its text line endings converted to Windows format, which ended up causing the issue you’re describing.

You are right, i am using Windows 10 for git.

Hey @TermiGR so I think this problem occurs when you pull the project using Git and then push with balena push. When you use Git on Windows it converts the project to Windows line endings when it pulls (allowing you to work on the project), and then converts back when you push. If you’re using balena push in this case, it doesn’t give Git the chance to convert back.

The key lines in your logs are:

30.05.19 11:09:47 (-0700)  pihole  [cont-init.d] 30-checktft.sh: executing... 
: No such file or directorypihole  ifelse: fatal: unable to exec bash
30.05.19 11:09:47 (-0700)  pihole  [cont-init.d] 30-checktft.sh: exited 111.

You’ve therefore got a couple of options:

  • Change your local Git settings to retain line endings - details here
  • Use the Git deploy method instead of balena push which would be git push balena master after adding the remote shown in the top right of your application in the dashboard. More details here

There’s another thread here which describes the same problem.

I hope this helps! Let us know if this solves the issue or if you need more help.

1 Like

Thank You so much! It worked! ;D