Can´t reach web interface

I signed up for a Balena Cloud account and installed a Pi hole about a week ago. Everything went well and worked as it was supposed to do. I have since then been running the Pi Hole and I have been visiting the web-interface several times. However. Today I could suddenly no longer reach the web interface. I have not changed anything except a patch cable between the Raspberry and the network switch, which ought to have no impact. Why can´t I reach the web-interface any more. What is a possible cause?

Best Regards

Hello @Humboldt, welcome to the balena Forums!

I’d be happy to help you with this. In order to give you a more accurate answer I’d like to understand what you mean when you say you can no longer access the web interface. Are you having issues logging in to balenaCloud or accessing the PiHole dashboard?


I mean the web-interface I reach on my local network, i.e. when I am writing the Raspberry’s ip number on my local network in the browser. I then used to get some statistics. I have no problem logging in on the Balena Cloud where I find info about my installation.

I can also mention that I in the log just found the following: DNS resolution is currently unavailable

One quick test to perform is, are you able to reach the IP Address of the PiHole from another device on the network? Do you have another laptop or PC that you can use, simply to see if that device can reach the Raspberry Pi properly?

Another potential thought, is it could be possible that the Raspberry Pi has received a new IP Address from your router. In the balenaCloud Dashboard, when you click on the name of your Pi, in the Device Details section you will see it’s current IP Address. Does this match what you are typing into the browser?

Of course, one final troubleshooting step is to simply reboot both the PiHole and the laptop or PC you are using, to see if that resolves the issue for you. Hope that helps!

Thank you for your suggestions dtischler, but
I have tried to reach the PiHole from different computers and from an iPad. Dosen´t matter. I can´t reach it from any PC.

The ip-adress in the router is the same as the ip-adress in the balenaCloud Dashboard. I can also mention that my PiHole Raspberry has a fixed ip-adress in the router. No DHCP.

I have also rebooted the PiHole several times. Does not help.


I’ve thought up several directions to go for further investigation:

Logs are always useful; Is it a correct assumption that the log from which you found “DNS resolution is currently unavailable” was that displayed on the balena cloud dashboard for the device, with timestamps after the most recent boot, that is, while it is unreachable on your dev environment’s LAN? There may be more of use in the logs to search for (or, posting them, with any info you wouldn’t post to a forum removed).

At the very least, if your device is sending logs home, it has an IP address on the network, since the API requests POSTing the logs to the cloud are in the application layer, requiring IP packets :wink:

If logs are sending, how goes SSH? Could you connect to the host and run ip a s to check the addresses assigned (if any) to wlan0 or eth0, etc.

You could also just run balena scan (Balena CLI Documentation - balena scan) to find the device on the local network. It may be that your static allocation (a config in the device itself, in its networkmanager profile, if I’m not mistaken?) did not work and it’s been given a random address by DHCP.

DHCP / static IP allocation issues in my experience are most directly investigated using one of tcpdump / wireshark / tshark capturing during the time the device is booted, while connected to eth / has its wifi card/drivers all ready to go. For wifi you can capture on a dev machine on the same network / in promiscuous/monitor mode, and for eth you’ll need a LAN tap / star (you mentioned having a network switch on the desk and some cables, so if you have an ethernet use-case, you’d be in luck possibly to have the means to sniff eth traffic.

These many directions may turn up something useful.

It was to tiresome to try to figure out what was wrong. I erased the whole PiHole and installed it again from scratch - as a new “device” in a new application. Now it works as expected again. Installed from a Linux-PC this time.

Another question. I have deleted the first “device”. But how do I delete the empty application?

Best regards

To delete an application there is a button in the action menu of the dashboard of that application.