pi images not working

I have both a mac with a dongle w/ a SD reader, and a windows slate with a built in SD reader.
I’ve downloaded Raspian lite, full, NOOBS, OSMC, and Ubuntu images so that I can play with various things. I have a raspberry pi 2, 3, and a 4.

I have very random results, but some images I have never gotten to work - do you have a best practices procedure I should follow? I get results from working as expected to just getting the pi splash screen to a dead card. It’s really frustrating as I feel it should be as simple as burn and go.

I’ve tried fast formatting, full wipe formatting, formatting to exFAT, etc - and I still get similar results.
Looking for maybe a rock-solid procedure.

Even using the OSMC provided imager, it works like 30% of the time. I truly feel like it is a SD format / set up issue.

Thank you!

You don’t need to wipe or format or anything else.
Just write the disk image to the SD card with Etcher.
Formatting the card first will make no difference.

What is “the OSMC provided imager” ?

Have you tried using another SD card ?

the OSMC imager is a specific SD burning software that OSMC provides:
" OSMC is well known for its ease of installation. To get started, simply select your current operating system to download the device installer. This will allow you to create a bootable image for any OSMC supported device."

Even this has unpredictable results, from the mac or windows 10 machines.

I specifically switched to Belena because I wanted to branch out from OSMC / Kodi (I’m looking at a PLEX server, using Docker, etc)

I have like 8 SD cards, 8 and 16 GB in size, all class 10. I literally will stack up SD cards, burn like 5 at the same time with the same image, and pop them in one at a time until one works. sometimes zero will work. I’m assuming the images are good as I get them from the source sites (Ubuntu for Ubuntu, OSMC for OSMC, Raspbian, etc…) My only other guess is bad / corrupt images. but I’ve re-downloaded those, too. I haven’t checksummed them, I’m an optimistic person and assume the best.

Seriously, I’ve been on computers since the 80s, an apple II+ was my first machine, I’ve formatted hundreds of disks and this just is both amusing and frustrating at the randomness of results.

The belena etcher never throws errors or anything, always has the ‘wanna burn another?’ message.

Yes, I’m old. :smiley:

So the problem is not related Etcher or OSMC, nor your computer (as you tested on a mac and on windows machines).
There’s no reason for the results to be random.
Check you SD cards one by one with something like H2testwor f3.

H2testw or f3

ok, I’ll look into that when I get home. Thanks!

(brew install f3) :smiley: