"Etched" RaspiOS / Raspian images not working

Hi there,
just wanted to let you know I ran into some weird problems while using Etcher 1.5.95 (both install and portable) on windows10. While it seems like a very easy to use program with nice features (auto verify etc) the images do not work correctly.
Right now I wanted to flash raspiOS-lite (2020-05-27) onto a 32gb SD card.
The card has been tested with h2testw. No errors.
The download has been verified via sha match.

When I flash the card with balena etcher, it displays no errors, verify says OK.
I can see the /boot directory in windows and even write the “ssh” data into it.
BUT: the pi will not boot up with the card now.
Tried it several times with installed and portable version 1.5.95.

Then I tested “win32diskImager” with the same image and sdCard afterwards; it just works on first try. Why is that, I wonder? Etcher is recommendet very often as THE image flashing tool. Did I do something wrong while using etcher - IS there something that can be done wrong? :thinking:



unfortunately I have no Windows 10 machine available but I have tried to reproduce this with the linux version of Etcher 1.5.95, 32GB SD card, raspiOS-lite 2020-05-27. Both RPi3 and RPi4 boot fine. Though this might be a Windows-specific issue, the codebase is common and Etcher should behave the same regardless on the platform. Could you please spare some more details?

  • Are you running Etcher as administrator?
  • Which version of RPi are you using?
  • What exactly do you mean by ‘the pi will not boot up’? Do you have a screen or a serial console connected and do they show any output?
  • When you say ‘write the “ssh” data’, what exactly do you mean? Did you do some modifications to the boot partition before actually booting the RPi? If so will it boot without those modifications?


I did run etcher as administrator several times, and several times without administrator rights.
I use a raspberryPi 4 4gb.
Unfortunately I do not have a display for the pi at hand, as I run it headless. I just don´t see it appear in my network and the SDcard activity led is not blinking for long after powering up.

With “ssh” I meant the small empty file called “ssh” to enable ssh right after fist boot. It´s necessary when using it headless. I wanted to say that I can access the data on the sd-card in /boot under windows 10 normally as it should be.


just to be sure, could you please confirm that the image SHA256 checksums are

f5786604be4b41e292c5b3c711e2efa64b25a5b51869ea8313d58da0b46afc64  2020-05-27-raspios-buster-lite-armhf.zip
3fe88721668543899fc8de9168bed798bdaa795b5a403f0332d7731b0afbaaa3  2020-05-27-raspios-buster-lite-armhf.img

I am quite convinced these will match but we want to rule out any ambiguities.


I did a sha256 check before flashing, and now I checked the .img again. The hashes do match.
As I wrote, I just flashed the same .img with another program (win32diskImager) and it creates a perfectly working sd-card, where “working” means the pi boots up as normal, is avaible in the LAN and accessible as it should be.

I have tried to reproduce the issue on my windows machine.

  • I used Etcher v1.5.95 (portable) [as administrator] to flash raspiOS-lite 2020-05-27 on a 32 GB SD card.

  • I used RPI4 and it is booting up fine.

  • I run it headless and it appeared directly in my network then I created ssh file after the 1st boot to enable ssh and was able to ssh it successfully.

  • Could you try another card? and let us know if this solved your issue?

It is weird. On my mostly used USB2 Port the image still does not work. But if I use another USB-port (usb3) the image works. I rarely use this port because it´s harder to reach and I thought with the slow SD-cards, it should not make a difference… (in speed, it doesn´t).
I still cannot understand why another flashing tool can create a working image on the other usb-port… but :man_shrugging:

thanks for your patience and help.

Hi, as an additional test could you try and use a different SD card on the older USB2 port and check if it makes any difference?

absolutely. will get to you later.