pi does not boot


My raspberry pi B+ rev 1.2 (2014) doesn’t boot with balenaos (try Raspberry Pi (v1 and Zero): BalenaOS 2.80.8+rev2 and Raspberry Pi 2: BalenaOS 2.48.0+rev1).

I use microsd 10C 64Gb and balenaEtcher-Portable-1.5.122.

What could be the reason?

there could be a variety of reasons.
First you should plug a TV/monitor via HDMI into the Pi. Then you should be able to see boot logs and any errors which might happen. (Be sure to use a development image)
Also do some LEDs on the board light up?
If you don’t even get so far, the SD card might be broken, the power supply of your Pi might not be strong enough (>2A is important) or the USB cable you’re using is of bad quality and thus doesn’t transfer the power well enough.
Did it work before with another OS?

Image doesn’t boot so I see nothing on TV/monitor (no logs, no errors). Leds are solid red and green always after start. SD card was flashed with raspbian before and after that and works perfectly as well as USB cable and power supply were not broken or weak. I tried both dev and prod versions.

Hello @CoDooku i think i missed that, but how are you connecting these Pis to the Internet? WiFi (2.4Ghz?)?

Let us know mroe details

No, ethernet. I also tried to use existing image and to prepare with cloud dashboard.

That’s very odd. Did you test with different USB cables? could you please confirm that the Ethernet cable and SD card works? Thanks!

It’s frustrating this moment when the devices are just not appearing but usually it’s some of these things.

Both cable and SD card are OK!

The solid LEDs definitely indicate the Pi is not booting. To clarify, you must use an OS labeled as Raspberry Pi v1 / Zero / Zero W. A Raspberry Pi 2 uses a different architecture, and an image built for the Pi2 will not boot on your v1 board.

The next thing to do for troubleshooting is to attach a serial cable to pins 6,8, and 10 on the GPIO to see if anything is being logged to UART console out.

Nothing! I see black screen everywhere.

But when I load raspbian all things are good!

@CoDooku are you testing with Development edition of balenaOS?

Could you please try with the latest balenaOS version for the pi Zero? or Pi 2? Thanks!

I tried with both dev and prod versions. What is the last version?

You can find balenaOS and the latest version released here: balenaOS - Run Docker containers on embedded IoT devices - if you’re using belanaCloud, it will obviously possible to just download the latest version preconfigured for your Fleet :slight_smile:

I tried balena-cloud-raspberry-pi-2.83.21+rev1-v12.10.3.img and nothing.

To be honest - the date on those files does not look too good (01.01.2098?)
Could it be that your Sdcard is defective?

I just tried the balena-cloud-raspberry-pi-2.83.21+rev1-dev-v12.10.3.img.zip ( the Raspberry Pi (v1 and Zero) Development Image from here: balenaOS - Run Docker containers on embedded IoT devices ) with an RPi 1B+ and it booted successfully. It took about 120 seconds to finally show the plymouth (logo screen) and load is quite high (over 2.07, without any container deployed) - but it works.

The RPi 1 generation is sadly starting to be a bit overwhelmed by balenaOS, however - in your case I would really try to use a different Micro SD Card.

1 Like

The problem is in image. I tried several sd cards and date was wrong for everyone as well as loading failed.

I can’t duplicate this … Trying my Pi 1 with a freshly deployed balenaOS 2.83.21+rev1 device boots right up (slowly, sure) and joins balenaCloud:

Hi CoDooku,
I also did open up my enclosure and looked at the RPi 1B+, it turns out also to be a B+ V.1.2 from 2014 (thats what the silkscreen says). I thought it might be a revision change or something, but seems likely we have the same hardware at hand…

Could you explain more about what you see and don’t see?
If I read correctly the display just stays black?
If you’re using a development image, the serial console of your RPi should put out data - so you could get a 3v3 TTL USB UART, attach it to the TX/RX/GND pins of your RPi and open it up with a serial console program like TeraTerm (I guess at 115200 BAUD) and see what it does… Could be that it outputs some more information there. But only on the development image, the production image does not come with that functionality.

You could try to read that logs and dump them here :slight_smile:


Good info @nmaas87 !

1 Like


It is strange but I force to work it. The problem I suppose was in sd card.
I use now typical 2Gb sd card (do not know class)

and dev version of balena os.

I’ll try to do the same with previous sd card and now I have another problem, the device doesn’t connect to balena cloud.