Pi 3 B+ v1.2 Not booting (7 blinks)

raspberrypi3

#1

Hi, my RaspberryPi 3 B+ (v1.2) doesn’t boot BalenaOS anymore (downloaded from the new device button on Balena cloud and flashed with Etcher), It worked some days ago when It was still called ResinOS…

The error is the same all the time, 7 green led blinks (*_*_*_*_*_*_*__) on the raspberry pi wiki documentation this indicates that the pi cannot find any kernel.img file.

I tried with the pi3 images 2.26.0+rev1 and 2.15.1+rev2 (both in prod and dev) without success.

Note: I can flash and boot Raspbian (tried with the lite version) with Etcher so the Pi itself isn’t the problem.

Anyone else seeing this recently ? :thinking:
Thank you for your time :hugs:


#2

Hi @tom,

I’ve got 2.26.0+rev1 & RPi 3 B+ on my desk and it works without any issues. I saw similar issue in this topic (Rpi 2 B+ v1.2 wont boot resin os v2.13.6+rev1) (7 led blinks) and it leads me to a thought - can you check that you’re flashing RPi 3B+ image and not the RPi B+ image, which is RPi 1? I may be completely wrong, but it’s worth checking.

Thanks.