balenaDash project not working

I am trying to get balenaDash to display a simple webpage and for some reason only the balenaOS logo is showing up. I have followed the steps outlined in the blog post “” However adding internal or external websites nothing appears. From the device nslookup resolves each sites I have tried.
I am running a Pi4 with balenaOS 2.53.12+rev1. All services are running and in logs I see kiosk running ‘cog

  1. I set the gpu mem to 396
  2. I set a device environment variable, WPE_URL, to a link … I tried several
  3. I reflashed multiple cards and tried two different device.
    When I run a device health check I am getting an error “Some networking issues detected:
    test_balena_registry: Could not communicate with for authentication”
    I am sure I am missing something simple but not sure what. Any help would be greatly appreciated.

Thank you!

Hi Ray,

Set the environment variable LAUNCH_URL to your webpage. The Pi4 uses Chromium, so the WPE_URL doesn’t take effect.


Sadly that’s not working either. I had tried it earlier as well and tried once more.

Ah - I just read the “cog” part. Is your application a RaspberryPi3 app, or RaspberryPi4? It needs to be the latter, and then the LAUNCH_URL will work.

It’s Pi4. I followed the blog post and used “deploy with balena” and choose Pi4

Hey Ray,

This is weird! Do you want to enable support access and I’ll take a look at the device and app?


Hey Phil,
Just enabled support. Is three hours ok? Thank you for looking into this. Truly appreciate it.


No worries - can you PM me the device UUID?

Hey Ray,

I’ve got good news and bad news.

You did nothing wrong.

I have no idea why the deploy button built the ARMv7 WPE dockerfile instead of the RPI4 one.

I’m doing a button release of my own now, into a Pi4 app - and we’ll see what I get.

Hold tight - it’s late here, and I might need to resume the fight in the morning, but I’ll get to the bottom of it. :wink:



Ah, somehow you have created a Pi3 application! See here:


I just build the Pi4 app, and it builds Chromium as expected. I think what you need to do is delete this application, push the deploy button again, set it like this:

and try again. If it still doesn’t do the right thing, then I’ll need to investigate further.


Phil, thank you so much for taking time to look into and my apologizes for missing this. After making the application to Pi4 it’s working now and all is good. Again thank you.