OrangePi Plus 2E Not Booting?

Hi there,

I’ve got an OrangePi Plus 2e here and was trying to get it going with (Dev / with WiFi)

I flashed v2.14.0+rev3 for Orange Pi Plus 2 device to uSD and this boots, shows the Balena splash, then shows a command line then a blank screen.

I understand this is a Beta but it looks as though others have this going.

Can anybody suggest where I might be going wrong here?




Did you downloaded the v2.14.0+rev3 from the dashboard link

If you downloaded it from the dashboard and the board it’s connected to the Internet it should show up in the dashboard after flashing.

Let us know more details about what is not working.


I did indeed. It isn’t showing up on the dashboard at all.

Are you using Dev / WiFi too ?


I just flashed this OS version and I hit this bug that was solved in OS version v2.15.0.

It’s possible that you encountered this issue also.

The easiest way to debug would be by using the serial console or the video terminal.

I would need the output of these commands:
systemctl status os-config
systemctl status openvpn

Please note that this bug doesn’t always reproduce.

It’s possible that flashing again your board it will work unless you are having a different problem.


So I tried the production / non-WiFi version to see if there was a difference.

This hangs too. I don’t think it’s an issue with my flashing of the uSD card.

There is something a little odd about an env file not being found on boot. I tried to capture that here. Not sure if it is relevant


NB. The board seems to boot fine with Armbian


The env file error is not a problem in this context.

As I was saying in my previous message, the only way to debug this, is for you to use the serial or video terminal console in the development build and give us the logs.

The output of these commands would help:
journalctl -u os-config --no-pager
journalctl -u openvpn --no-pager

I’ve got a monitor and keyboard on it. My problem is it completely locks up. For example I can’t change the green caps lock light on the keyboard…


I’m thinking maybe your power supply is not supplying enough current.

At what voltage/amperage is your power supply rated?

It’s the one that came with the board, rated at 5V / 3A


The power supply seems fine.

I’m using an Orange Pi Plus2 vs. Orange Pi Plus2e that you are using.

The differences don’t seem to be too big at first sight. Just some extra USB ports on your board. But it maybe something else that makes your board freeze.

Could you use a USB-UART cable to access the serial console and see if you can take some logs?


I don’t have a USB-serial adaptor to hand but I can dig one out.

In the meantime I’ve flashed and booted up the Debian image which seems to work fine.

Keyboard/Mouse/Display/Desktop/Ethernet all working fine.

The Orange Pi Plus 2 (BETA) image does support the Orange Pi Plus 2E I guess?



Hi @ajlennon,

I will send you an Orange Pi Plus 2E device tree that you can replace on your card and it’s possible that it will work.

Unfortunately I don’t have an Orange Pi Plus 2E board here to test. I only have the Orange Pi Plus 2.



Hi @ajlennon,

Could you please replace the sun8i-h3-orangepi-plus.dtb file from your SD card flash-boot partition dtb folder with the file from the bellow link? And then you can try again.

The file I gave you link here is a device tree compiled for the Orange Pi Plus2e board.


Hi @spanceac,

Thanks. That gets me a bit further. The keyboard is now recognised. It gets as far as starting to connect to the cloud and then locks up. e.g. every time I boot up the board I get a new device appearing on the app with “connecting” and then it locks…

Here’s a video showing what’s happening

Googling around the only difference seems to be a lack of a SATA port on the 2E?,113/

Hi @ajlennon,

The card that you insert into the board is for flashing the OS on the board’s eMMC.

After the flashing procedure is done the board will shutdown itself.

Remove power from the board, extract the SD card from the board and apply power again to the board.

It should appear as online in the dashboard if all is fine.


1 Like

Aaaaaah - well don’t I feel like an idiot!

That’ll teach me to think I know what I am doing and not read the instructions :blush::blush::blush:

Connected and working!

Thank you so much @spanceac !

Hey @ajlennon,

Everyone’s guilty for not reading instructions properly :smiley:

Could you please try again with the un-modified image where you don’t replace the dtb and see if it works? Just that we know if the default image works for Orange Pi Plus2E also.


I’ll do that now!