RPI2 2.43.0+rev1 7 flashes

Hello guys,

I’ve RPI2 B and can’t boot balena os 2.43. I get 7 flashes. I can boot raspbian with the same sd card and rpi2. My balena application is RP2. Any ideas?

Hey there!

Sorry to hear you’re having issues. Have you checked the following section of our documentation: https://www.balena.io/docs/faq/troubleshooting/troubleshooting/#cant-boot-the-kernelimg? It describes a problem very similar to yours (7 LED flashes), and it usually happens when not running the right OS image for your device.

Are you absolutely sure that its an RPI2 B, and that the image I also a RPI2 one?

1 Like

Yes, I’ve been using it for years. I also have a RPI3 and it is onboarded without a problem.

This is my os-release file from the downloaded image.

PRETTY_NAME="balenaOS 2.43.0+rev1"



and beginning of device-type.json

"slug": "raspberry-pi2",
"version": 1,
"aliases": [
"name": "Raspberry Pi 2",
"arch": "armv7hf",
"state": "RELEASED",

That is very strange. Do you the same issues when flashing another balenaOS version, older or newer? If there is a bug in balenaOS, then figuring out the problematic version might help us solve it really quickly.

1 Like

I tried v2.36.0+rev2 and got the same error. Weird part is I can’t boot ubuntu core too but raspbian (2019-09-26-raspbian-buster-lite) works flawlessly.

What LED patterns do you get when trying to boot Ubuntu Core? Maybe that gives us some more information?

I get 7 flashes from ubuntu core too

What SD Card brand and model do you have? Can you try with another one, just to rule that out?

I have transcend 4gb and samsung evo plus 32gb sd cards. I can boot RPI3 with both of them but neither can boot RPI2.

I think the SD Card might have something to do with it. Can you try a different SD Card on the RPI2? If so, we could proceed to investigate why that card is problematic for the pi 2

I’m sorry I don’t have any other cards besides those two. Can you explain why do you think it might have something with the sdcards? 2 different brand, model, size and both works with RPI3 and raspbian but none of them works with RPI2. What am I missing here?

Hi @uriandwubber, @jviotti suspects that this issue might be related to SD card. If you have a chance to try out another SD card, it’d be good to rule it out.

Then as for other means to troubleshoot this: Can you hookup a serial cable to it?

By the way, do you experience the same issue with both development and production variants of balenaOS?