Only Audio is Bluetooth Bing


I’m trying to run Balena Sound with a Raspberry Pi 3 and a hifiberry plus pro DAC.

When I connect and disconnect my phone to the bluetooth audio, I get the sound effect coming through the RCA jacks, but when I try to play anything through the bluetooth connection, there is no sound.

Hi, have you also added the hifiberry-dacplus overlay in dtoverlay in the balena dashboard Device Configuration section?

Yes I have.

What does aplay -l return?

root@d1d0cd4:/# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0
Subdevices: 1/1
Subdevice #0: subdevice #0

Can you try to play some file in your container? Something like aplay /usr/share/sound/alsa/Front_Left.wav ?

I can’t find that wav file. It returns no file or directory.

Edit: Ah, it was in “sounds” not sound. It does not play anything.
aplay does show:
Playing WAVE ‘/usr/share/sounds/alsa/Front_Right.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

Hey there @nic

I’ve just been taking a look at this and I wonder if it’s something as simple as the volume being turned down? If you’re hearing the sound effects playing via the DAC when you connect that proves the device is working OK.

The command that executes when you connect a device is: aplay -D hw:0,0 /usr/src/sounds/connect.wav (see here). Therefore if you run this command you should hear the same sound or to use the sound effect described above: aplay -D hw:0,0 /usr/share/sounds/alsa/Front_Left.wav. Either of these should give you some audio. If they aren’t then it’s probably a volume issue - you’ll see in the script the system adjusts the volume before playing the connect/disconnect sound to make sure it’s heard.

You could also try running alsamixer which will give you some control over the output volume, or you can also set the SYSTEM_OUTPUT_VOLUME environment variable a bit higher (by default it is set to 75), as well as making sure your bluetooth device is turned up when you connect.

Keep us posted with your progress!

Update: I tried the 64-bit OS and the Development version of the RP3 OS. Neither worked. Tried to up the system volume through SYSTEM_OUTPUT_VOLUME, no dice. Not sure what to try next.

Could you please try to create a new application and choose the device type to be RasperryPi3, which is the 32-bit OS and not the 64-bit?
I believe this will resolve the problem, so let me know how it works for you.