No audio, getting SBC decoding error and Cannot set requested source latency

Hi, Have recently tried this tutorial. Its really amazing and installation and configuration and booting device up and running is just piece of cake up till connecting to Bluetooth device on all devices, but only problem I am not getting any audio, could be issue with latest release I guess. I am seeing 2 errors on logs.
1. audio W: [pulseaudio] module-loopback.c: Cannot set requested source latency of 66.67 ms, adjusting to 68.54 ms
2. audio E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-2)

Note: I am using RPi 3, connected to Bose Revolve ++ speaker using 3.5 audio jack (Using Bose for testing, main purpose is to connect to Sony Home theatre doesn’t have bluetooth support). Tried connected my iPhone & Macbook Pro to balenaOS xxxx, but no audio. Always getting above 2 errors. Kinding help me on this, or can I try with previous versions?

Below are some Info about OS version I am using:
OS Version: balenaOS 2.60.1+rev1 [Production version]
Current/Target release Version: a0ac718

Hi BalenaSound Team, FYI, Have tried with previous version balenaOS 2.58.3+rev [Production], it works like charm. I guess this issue with balenaOS 2.60.1+rev1 [Production]

Thank you for the report, we’ll take a look into this.

Hi Arun, thanks for the heads up. We’ve seen SBC errors reported for some users in the past but haven’t figured out a solution yet as it’s very hard to replicate consistently. We think it’s related to a known problem with the Pi3 chip, you can read more about it here:
Interesting to know that previous balenaOS version helped, I might look into that as well to see if we changed something that could explain it.