No sound when connecting through bluetooth

I can connect to the balena device using bluetooth, but when I stream Spotify after connecting, no audio is coming through.

I restarted the bluetooth service, no luck. Any pointers?

I picked up the following in the log

8.10.20 18:41:40 (+0200) audio W: [pulseaudio] module-loopback.c: Configured latency of 200.00 ms is smaller than minimum latency, using minimum instead
08.10.20 18:41:40 (+0200) audio W: [pulseaudio] module-loopback.c: Cannot set requested source latency of 66.67 ms, adjusting to 250.00 ms
08.10.20 18:41:46 (+0200) audio E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-2)
08.10.20 18:41:46 (+0200) audio E: [bluetooth] module-bluez5-device.c: Decoding error
08.10.20 18:42:09 (+0200) audio W: [pulseaudio] module-loopback.c: Too many underruns, increasing latency to 220.00 ms

Hi there – thanks for getting in touch with us. Let me ask some questions:

  • I presume you’re asking about the balenaSound project. Is that correct?
  • Can you confirm what kind of device you’re running this on? If it’s a Raspberry Pi, can you confirm the version?
  • When you run Device Checks from the Diagnostics tab on your device dashboard, does it give you any warnings?
  • What happens when you try the troubleshooting/workaround steps in the “Audio cuts or is very stuttery” section of the balenaSound support page? Although the symptoms described there are a bit different, it’s still related to bluetooth performance problems and may offer some help.

All the best,

Hi Hugh
Yes, Sound project
It is running on a Raspberry Pi 3B+
All checks are green.
I have disabled the multi-room server and client, but still the same issue.
I will test with a bluetooth dongle.

It seems to me that bluetooth is very buggy on RPI3, so I will not spend too much time on that, thank you for the pointers.


The Pi3B+ has better bluetooth than previous versions, but we do still see issues when users are using both WiFi and Bluetooth at the same time. I think your options are either to run the device over ethernet (if that’s possible) or go with a bluetooth dongle as you suggest. These at least provide a separate radio and normally have a higher gain antenna.

Do let us know how you get on.


I’ve the same problem, I’ve bought a bluetooth dongle to solve it.

My question is: how I can disable internal bluetooh from balena dahboard ?

Can’t found any information about that in documentation or in forum thread or github issues.


Hey there,

According to the troubeshooting guide balenaSound will automatically deetct the usb bluetooth dongle and use it.

As for disabling bluetooth maybe you can try dtoverlay=pi3-disable-bt. You can add this via balenaCloud dashboard as a config variable. you can read more on how to do this here

Hope this is helpful

1 Like

thanks for your answer,

I’ve disable rpi bluetooth with dtoverlay=pi3-disable-bt and I use the dongle instead but I still experience the same issue.

12.10.20 19:53:48 (+0200)  audio  E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-2)
12.10.20 19:53:48 (+0200)  audio  E: [bluetooth] module-bluez5-device.c: Decoding error
12.10.20 19:55:00 (+0200)  audio  W: [pulseaudio] module-loopback.c: Cannot set requested source latency of 66.67 ms, adjusting to 68.54 ms
12.10.20 19:55:00 (+0200)  audio  E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-2)
12.10.20 19:55:00 (+0200)  audio  E: [bluetooth] module-bluez5-device.c: Decoding error

Do you have an idea ?


Just to clarify, the configuration variable should be RESIN_HOST_CONFIG_dtoverlay=pi3-disable-bt. Is that what you tried?



I’m also using a dac and another variable was present by default, so I have :


ok, I’ve try different combinations of quotes around these variables and now, it seems ok !

To those with the same problem, here is my configuration

Thank you Simon for showing your correct configuration!