Music will skip and or pause using Balena Sound

I have been running the Balena Sound project on my Raspberry pi 3 for a little bit now but have been noticing that it sometimes will pause or skip when playing music from my iPhone. Looking at the logs I notice that there are still some errors coming through

25.09.19 11:24:40 (-0700) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 8273 != 8271
25.09.19 11:24:50 (-0700) bluetooth-audio /usr/bin/bluealsa: SBC decoding error: No such process
25.09.19 11:25:27 (-0700) bluetooth-audio /usr/bin/bluealsa: SBC decoding error: No such file or directory
25.09.19 11:25:27 (-0700) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 11533 != 11514
25.09.19 11:25:46 (-0700) bluetooth-audio /usr/bin/bluealsa: SBC decoding error: No such file or directory
25.09.19 11:25:46 (-0700) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 12807 != 12804

for example. I do not have any other bluetooth devices connected to it and the raspberry pi is sometimes within arms reach. The raspberry pi is using a IQaudIO DAC+ with a case, but not really sure what else.

Hey, thanks for reaching out.

The logs seem to point at the RTP packets getting dropped, probably due to signal. There are some similar issues I came across after some Googling so maybe you could try either an external Bluetooth adapter, or disabling WiFi (if it’s not being used).

If you do try either of these then please update back here if it make a difference, thanks :+1:

@richbayliss
I have read some of that as well. So I have turned the wifi off onboard the pi and the problems still persists. I ordered a bluetooth dongle to see if that works, as it seems to have started when I used the the DAC, which covers the pi. Will report back with any updates

Please have a look at BalenaSound on PI0 W with phat dac - Garbled sound glitches off intermittently, maybe these threads should be merged?

Hey @had42, after checking the post suggested by @ktg ( BalenaSound on PI0 W with phat dac - Garbled sound glitches off intermittently ), the issue is due to the new iOS13 update.

Do you have an older iPhone or another phone to test it?

Cheers

@dansku
Well thats the odd part. When I first did the project I was already on iOS 13 beta, and I had no issues with the sound (other than the actual onboard audio not being the best). I only started seeing the dropping sound issue after adding the DAC. I was able to check with an iPad 2 running iOS 8.4.1 (a bit old, I know) and it was able to connect but still ran into the issue of skipping and pausing with these errors in the console

05

Full summary of what Im running is:

  • Raspberry Pi 3
  • BalenaOS 2.43.0+rev1
  • IQaudIO DAC+
  • dtoverlay=“disable-wifi, iqaudio-dacplus”

Hi @Had42

I don’t know if this is relevant for yours but another setting I had to change for the pHat Dac was:
Define DT parameters [RESIN_HOST_CONFIG_dtparam] and turn audio to off (“i2c_arm=on”,“spi=on”,“audio=off”)

Hope this helps.
@KTG 's solution was totally spot on for me.

ADDITION:
I just tried my old ipad2 with iOS 9.3.5 and although it was nowhere near as bad as my iphone 8 running iOS 13. The sound was much quieter and every now and then glitched off. also it was missing RTP Packets constantly. Works perfectly on my old iphone 5 running iOS 10.3.3.

@dansku

So an update on my setup. I added a bluetooth dongle to my raspberry pi 3, turned off onboard bluetooth, as well as wifi. reset all variables and got the dongle to show up. From there I did an initial 10 min test of the audio and was pleased that I no longer get the error

SBC decoding error: No such file or directory

I still am getting the Missing RTP packet: errors

but audibly this only happens every so often and there is only slight skips, no pauses. So still not fully sure of the the missing packets but it definitely sounds better than before

Hi @Had42, nice to hear that the bluetooth dongle resolved the error and the sound is better. That’s progress : )

Missing RTP packet implies a weak bluetooth signal. Is the bluetooth source (iPhone) close to the RPi3? Do you see the same error logs with other bluetooth sources?

Next, are there other bluetooth connections to the same device?
It’d be good to make sure there is only 1 bluetooth connection active – which might help with this issue.

Finally, could you check if there is any kind of power saving mode enabled on your iPhone or the music app?

We saw cases that power saving mode causing similar issue.

@gelbal so with the Bluetooth dongle I added I was able to test the playback for a good solid hour, and when I was in the room I experienced no dropped packets or error. Leaving the room would cause the errors again, so a as for me I’d say my issue has been solved