BalenaSound on PI0 W with phat dac - Garbled sound glitches off intermittently

Hi, I am a bit of a noob with Pi stuff etc but not technically daft. I have just completed the BalenaSound Bluetooth project and although I connect ok with the bluetooth the audio is not great. It sounds slightly garbled, like it’s got some sort of filter effect that makes it sound like it’s being played underwater (just slightly though). The other problem is it plays the audio for maybe 6 to 10 seconds then glitches off for a second then plays again for another 6 to 10 seconds then off again for a second throughout the entire playback.

I have checked the phat dacs header soldering with a lupe (powerful magnifyer) and all looks good. I’ve also checked every pin for shorts and for continuity with a meter and all seems fine there too. The pi Zero was a presoldered one.

very stuck with this. Have searched google extensivly but to no avail. Would really appreciate some suggestions / assistance on this.

Hi @bonarhya I assume the Pi0 is using the wifi simultaneously while streaming over bluetooth? I remember reading that since wifi and bluetooth are handled by the same chip/firmware, that wifi usage can negatively affect the bluetooth A2DP stream. One test would be to try connect up a usb ethernet cable and disable the wifi and see if it improves things.

Thanks for answering @shaunmulligan, much appreciated. I will look into that, see how to do it and give it a try. Not sure how to get into the Pi0 tbh, as not actually been in there or connected it to a monitor. I did the whole project from tutorial in my balenacloud account and terminal cli tools commands ! no idea what login name and password are going to be??

Hi, if you mean the login from the balena CLI, they’re going to be your credentials for accessing the balenaCloud dashboard.
Keep us posted when you test it with an ethernet cable if it works! If it doesn’t, you could try with a different device too (always pi0 if possible)

Hello.
I think this behavior is to lead back to the new ios Version 13…

As I updated my iPhone to iOS 13, i had exactely same behaviour.

But my wife was still on iOS 12.x… and it worked for her. We are usuing 3 of balena Sound RPi 0W. The behavior was exactely same on all 3 of them. Since my wife updated to iOS 13.1 she has the same problem. Balena Sound become unusable :frowning:

But the general bluetooth connection works with all other bluetooth receiver, like our cars, Audioengine B1, Technisat Internet Radio, Panasonic and Beats headphones, etc. But it will not work with balena Sound with same behavior on all 3 RPi’s, while another Android Phone can still use it.

I think, apple has changed something in the bluetooth-connection in iOS 13.x. This is what you should have a look at it.

Please have also a look at: Music will skip and or pause using Balena Sound

@KTG Thats really interesting observation, the odd thing is I was on the iOS 13 & 13.1 beta for a while, even before starting the Balena Sound project, and I didn’t have any latency or dropped packets until I started using the DAC+

Hi KTG

Typically I just updated my iphone to ios13 just last week lol.

Thank you so much for the answer. I charged up my old iphone 5 which has an older ios and low and behold you are spot on correct. The sound was fantastic, no garbled noise no cutting in and out. It sounded really good. Atleast I now know my soldering was ok and the pi and dac are fine.

I really hope Apple make a fix for this in ios 13. I suppose it should be reported to them as a bug or something, perhaps we should all report it so they can get working on it :slight_smile:

Again Thank you so much for the help.

Hi Had42

KTG’s solution was exactly what the problem was for me. IOS13. Using a different phone with older ios was excellent. I’m so pleased. Just gotta get Apple to create a fix now. That should be fun lol.

Hi @thundron

@KTG 's solution to the problem was exactly correct for me. The new Apple ios13. Older ios works a treat.

Thanks for your input though it was really appreciated.

@bonarhya, unfortunately, I think, it isn’t a problem of iOS, because it works with (my) other bluetooth receivers, as i wrote before… :frowning:

hi @KTG

You are correct again. I just tried it with an old i-link I have and it works perfectly.

The new iOs 13 must have either broken the BalenaSound code or is no longer compatible with Pi Zero w / pHat Dac.

Wonder if it does the same if the projects made on a different Pi model ?