macOS 10.14.6 balenaEtcher something went wrong Lubuntu.iso

Hi, I have a similar issue as in Write error to USB (MacOS), but on macOS 10.14.6, latest balenaEtcher 1.5.109, trying to flash a lubuntu-20.04.1-desktop-amd64.iso to usb.

Using a 15’ MacBook Pro 2013 and Sandisk Ultra Fit 3.1 flash drive.

I didn’t want to disable SIP.

I tried different downloads from the Ubuntu site and tried moving the .iso to another dir, but it keeps failing to:

Attention
Something went wrong. If it is a compressed image, please check that the archive is not corrupted.

The writer process ended unexpectedly

I found the quite similar but old topic Keep getting "something went wrong." error on Arch which boils down to the advice to use the quite old version 1.5.60.

I found this and it seems to work. It flashes the usb. I haven’t tried to use it though.

I thought you’d like to know.

Hi, thank you for letting us know. I don’t think there’s much we can do in this case as we need access to some temporary folders located in the protected folders, but we’ll keep it in mind in case we can do something in the future.

I don’t understand what you mean. I’m not familiar with the matter so I wouldn’t know why Etcher needs access to specific macOS folders, other than the .iso and the usb. Is there something fundamentally different to the recent versions, compared to version 1.5.60?

If it’s helpful for you, I can test something.

BtW The goal was to install Lubuntu on a Dell laptop with the resulting USB stick and that worked fine :slight_smile:

Hi @laptopleon,
we use a temporary folder to decompress the file before flashing which makes it faster, so we need access to that folder. I’m afraid there’s no way of having an exception for the SIP, so the only option is to either disable it or downgrade to a version that doesn’t decompress first (like 1.5.60 if I’m not mistaken).

Please let me know if you have any further questions.
Georgia

Thank you.

I’m no expert and I surely don’t want to be ‘that guy’, but of course, SIP is there for a reason. I’d think that Apple has thought about this and provides a way to handle situations like this?

It really didn’t take that long in my case. Probably, most users won’t have to do this often anyway. Is it an idea to simply make the decompressing optional? I would’ve been much easier and faster for me to just use that option. Disabling / re-enabling SIP, if I recall correctly, requires restarting and terminal usage a few times.

At least please make the error message clearer, so that users know SIP is the problem. “Something went wrong.” isn’t very helpful.

I’d think that Apple has thought about this and provides a way to handle situations like this?

Unfortunately we had to make other changes to make Etcher work on macOS Catalina too which greatly reduced the effort on other minor issues wrt macOS and we have still have a very busy queue for other functionalities.
Decompressing the image first greatly reduces the time taken to flash it and is usually a very short operation (if done before and not during flashing), so perhaps you could consider extracting the images first whenever possible.
About the error being clearer - there are so many edge cases for Windows, macOS and Linux that it’s often hard to figure out the exact way to present them, especially when they might be too generic to point out at a specific issue (access to a folder might not be limited only to SIP).

Hi geaorgiats,
I have a macbook air Catalina 10.15.7 and am using balenaetcher 1.5.109 and have been trying to flash ubuntu-20.04.1-desktop-amd64.iso to a 8GB usb. I have tried different things i’ve seen to make it work such as opening balena as sudo, moving ubuntu to the “package contents” of balenaetcher, and I have also disabled SIP on my mac to install balenaetcher and flash ubuntu, however, after the validation process gets to 99% I get a pop-up message saying “the disk you inserted was not readable by this computer” and on the balenaetcher window I get “flash complete” and underneath a red circle next to “1 failed target”.

to check if the usb worked, I flashed balenaEtcher-1.5.109.dmg and it worked (not sure if file helps to see if the usb works), i did not get the message that the disk was not readable in this computer.

I do not know what else to do.

Thank you!

Hi Ivan, are you able to try flashing that same Ubuntu image to another USB drive? Does it work on a different drive, by chance? Just wondering if there is a failing block on the USB stick you are using, perhaps.

Hey dtischler, I actually tried using a third and larger usb (16GB) and it worked!! It also flashed faster than with the previous usb’s I used. Anyway thank you for you respones :slight_smile: