Balena-Etcher giving error!

Guys, I’m trying to record an iso of a Debian Live on a Kingston Data 3.0 pendrive using Balena-Etcher 1.5.102. It was installed via Appimage and when started it does not report any errors. I select the iso and the pendrive but when I provide the password after clicking “Flash”, it displays the following error message:
Imagem hospedada por
I’m using an Acer Nitro 5 Laptop running Linux Mint 20.0 Cinnamon, version 4.6.6 and Kernel 5.4.0-42 - generic.
Best regards
Antonio Carlos

Hello Antonio, welcome to the forums and thanks for trying out Etcher. Is this the first time you are flashing this ISO file? Are you sure it’s not corrupted or download failed mid-way? That’s the first thing I would check, if you are certain that the image is good then we can explore other troubleshooting options.

Hello tmigone, I think the problem is not with the ISO file because I created a USB stick (which I even installed on an external HD on the same Laptop) using the same ISO file through the “unetbootin” application and it worked fine.
I have tried several ISO files and also several Pendrivers and it always gives the same error.

Hi. Could you try running Etcher with sudo from the start?

Well, I just have Etcher using Appimage. I didn’t get install it trhou apt-get or dpkg. Do you want I run Etcher using appimage in a terminal?

Yes, with sudo (or any other sudo-like command, like gksudo for example): sudo ./balenaEtcher-1.5.102-x64.AppImage (if you’re using the 64-bit version)

I used sudo /home/nogueira/Applications/balenaEtcher-1.5.102-x64.AppImage and I got:
Imagem hospedada por
I especify /home/nogueira/Applications the directory where I save the Appimage applications. Not in /root.
Now I can’t run it anymore. If I try it return error

Ah, you’re using AppImageLauncher. It seems to break with sudo: Unfortunately, it seems this can only be fixed by reinstalling AppImageLauncher. On top of that, this comment and these two issues (1, 2) suggests that Etcher and any other appimage requiring root privileges cannot be run through AppImageLauncher at all.