macOS Catalina 10.15 and 1.5.59 error

Hi, I’m on macOS Catalina 10.15 and my Etcher has stopped working after I upgraded to the latest version available for download - balenaEtcher-1.5.59.

Once installed and fired up I get this message (below) cheers.


Just to add, using

sudo /Applications/

gives the same error box.

Ok so i fixed it :see_no_evil:
Just incase anyone has similar problems - the security settings defaulted back to locked down after OS update.

From security settings, I just hit “open anyway”

However, it wouldn’t let me burn any image to USB unless i opened via suso and drag and dropped the img file in from finder

1 Like

Hi and welcome to the forums!
We’re tracking this issue here for which we have a PR on the works that will add notarization to Etcher for macOS Catalina.

Side note: you might still need to run Etcher with sudo /Applications/... in order for it to be able to write successfully on Catalina

1 Like

I was having trouble getting this to work on Catalina but this worked for me.
I wanted to post the specific terminal command which worked for me since I wasn’t sure what the “…” meant.
In terminal put: sudo “/Applications/”