local mode - testing changes


I’ve been working through some changes for my github project. However I’m struggling to get my changes tested locally.

I’ve made my changes on branch:develop & although it’s checked out & active. When I run balena push -s . from within my source directory I get the old version without my changes running on my Pi

What should I be doing here to test my changes locally before deploying?

Right, I’ve spent 2 evenings trying to get this working. As far as I can tell balena push is not building my local version

I’ve tried
• Logging into device, running various docker commands balena system prune, removing the old containers
• Different image (PiHole) as this does seem to load PiHole
• Changing balena yml (name + url)

Regardless however when triggering balena push I still keep getting the old images:

root@9e3da5b:~# balena ps
CONTAINER ID        IMAGE                                                                   COMMAND                  CREATED             STATUS                    PORTS                NAMES
dc6b39561434        1f112809d961                                                            "./start.sh"             17 minutes ago      Up 17 minutes                                  fbcp_3_1
2afadc957f3d        d2e032d4a69a                                                            "/docker-entrypoint.…"   17 minutes ago      Up 17 minutes   >80/tcp   netspeed_1_1
01642bdf46fc        fa7ca3bc2ac4                                                            "bash start.sh 'expo…"   17 minutes ago      Up 9 seconds                                   browser_2_1
52497eeb30c0        registry2.balena-cloud.com/v2/3a9066ce744bf2ed13c472c8e827c924:latest   "/usr/src/app/entry.…"   About an hour ago   Up 25 minutes (healthy)                        resin_supervisor

See above, netspeed_1_1, is running image from registry2.balena-cloud.com/v2/3a9066ce744bf2ed13c472c8e827c924:latest, when it should be running the local version

Hi @ryandev, I’m not sure I follow you. The console output you shared is saying that resin_supervisor container which is our on device supervisor is running registry2.balena-cloud.com/v2/3a9066ce744bf2ed13c472c8e827c924:latest.
You can inspect balena image ls to see what the image source for those containers is, and wether they are built locally or served via our cloud.

Here is sample output from one of my devices in local mode, as you can see images built locally using local mode/livepush are prefixed with local_:

root@balena-9:~# balena ps
CONTAINER ID        IMAGE                                                                   COMMAND                  CREATED             STATUS                             PORTS                  NAMES
d701e1aa4061        a856e6c10d42                                                            "/usr/bin/entry.sh /…"   5 days ago          Up 5 minutes                                              avahi_3_1
9540a8d8736e        dad90866d171                                                            "/docker-entrypoint.…"   5 days ago          Up 5 minutes             >80/tcp   webservercopy_2_1
a1660d15bdf5        dad90866d171                                                            "/docker-entrypoint.…"   5 days ago          Up 5 minutes             >80/tcp     webserver_1_1
45caa2d547c8        registry2.balena-cloud.com/v2/3a9066ce744bf2ed13c472c8e827c924:latest   "/usr/src/app/entry.…"   5 days ago          Up 16 seconds (health: starting)                          resin_supervisor
root@balena-9:~# balena image ls
REPOSITORY                                                       TAG                 IMAGE ID            CREATED             SIZE
local_image_avahi                                                latest              a856e6c10d42        5 days ago          83.5MB
<none>                                                           <none>              a520ced6e02c        5 days ago          83.5MB
<none>                                                           <none>              5fe8c360a5c2        5 days ago          83.6MB
<none>                                                           <none>              9dc9096b293f        5 days ago          83.6MB
<none>                                                           <none>              72cee2e901a5        5 days ago          209MB
<none>                                                           <none>              f0479f32b9bf        5 days ago          209MB
<none>                                                           <none>              a74e1e6a0d38        5 days ago          209MB
<none>                                                           <none>              bc054eff80d8        5 days ago          164MB
<none>                                                           <none>              38495a2c13e3        5 days ago          164MB
registry2.balena-cloud.com/v2/24d227324e4d9eef1d9eb3df75db1008   <none>              d1d4918925e4        12 days ago         176MB
balenalib/raspberrypi4-64-debian                                 latest              3f6358dfa109        13 days ago         164MB
balenalib/raspberrypi4-64-alpine                                 latest              e54669187df1        13 days ago         83.5MB
registry2.balena-cloud.com/v2/3a9066ce744bf2ed13c472c8e827c924   latest              7505b0572456        4 weeks ago         72.5MB
balena/aarch64-supervisor                                        v12.5.10            7505b0572456        4 weeks ago         72.5MB
local_image_webserver                                            latest              dad90866d171        2 months ago        21.2MB
local_image_webservercopy                                        latest              dad90866d171        2 months ago        21.2MB
balena-healthcheck-image                                         latest              a29f45ccde2a        16 months ago       9.14kB

Hey @ryandev, Let us know if you’re still having problems with this.