Local mode development -- how to diagnose a failure to "balena push 10.168.50.81""

When I execute balena push 10.168.50.81 I get:

Could not communicate with local mode device at address 10.168.50.81

I’ve checked that I’m running a development variant of the OS, local mode is enabled on the device, the ip address is from sudo balena local scan. The only requirement missing is I’m using ResinOS 2.14.0+rev4 because that is all that is supported by the CTI Orbitty TX2 devices.

Are there any other things or logs I can check? I can ssh into the device, but that uses the uuid not the ip address.

Hi ! I think this might be it - the local mode needs a newer version of the OS - we can let you know when there is a new OS version available for that device. I can see we have 2.31.2+rev1 in our tetsting for that device right now.

Interestingly, the local scan tells me the BalenaOS version but the push doesn’t report any details of the connection problem. I’ll file an issue.

Hi. The new OS version for this board has been released. Can you give it a try please and let us know if it works okay now?

Hey @jason10 we have now released 2.31.5+rev1 version of the OS on the CTI Orbitty TX2 board. I believe this should fix the issues you were experiencing with localMode pushes.

Let us know if you have any issues when you get a chance to upgrade the OS and test 'balena push

Thank you, we will test this and get back to you!

@pdcastro I work with @jason10 and I am attempting to get local mode to work with a CTI Orbitty TX2 board.

I reflashed my Orbitty/TX2 with 2.31.5+Rev 1 (development).

I enabled local mode in the dashboard.

When I execute the command “balena push 192.168.0.28” it builds and deploys, but when it tries to start I get the error message “./hw_mon: cannot execute binary file: Exec format error”, exit code 126.

@pdcastro, @jason10

Local push to a CTI Orbitty TX2 is working with 2.31.5-Rev1.

I hadto modify the makefile to compile for -mcpu=cortex-A57+crypto and now it’s working.

@equack, that’s awesome, thank you for the feedback! :+1: