Enable local mode for local push

Hi all,

I’m currently developing an internal application via openBalena, but I’ve stumbled upon a development issue. I can’t seem to enable local mode on a openBalena development device, so that I can use the command balena push <ip address>. Is this not supported yet, or do I need to know a workaround for this? Because building my application, pushing it to the openBalena server and then waiting for it to download isn’t the most efficient :slight_smile:

Thanks in advance!

1 Like

Hi @vedicium,
From the Balena Documentation, these are the requirements for local mode push:
In order to use local mode on a device:

  • The device must be running balenaOS v2.29.0 or higher.
  • The device must be running a development variant of the OS.
  • You must have the balena CLI installed on your workstation.
  • Local mode must be enabled through the dashboard. To use local mode on a development device, click on the small Actions dropdown at the top right of the device page and select Enable Local Mode .

Hi @controlsgeek,

Thanks for your reaction. That’s indeed how to set a device in local mode. However, the Balena Dashboard is only available in cloudBalena, and I’m asking for openBalena. So that’s why I’m asking. But anyway, thanks for taking the time to help me out! :slight_smile:

Sorry! Failed to notice that. Will follow the question!

Hey,

So I just tried this and it worked OK for my on my Intel NUC device. You must have a development image running on the device for this to work, and you must then put the device into Local Mode, which I did application-wide, like so:

# balena env add BALENA_SUPERVISOR_LOCAL_MODE 1 --app MyApp

Then in my application source directory I ran:

# balena push 1.2.3.4

where 1.2.3.4 was the IP of my device.

This worked fine for me, and my app is running nicely on my device :tada:

Awesome! I’m going to try that as soon as possible and post my findings here! Thanks!