Local deployment stuck in balena cli version v17.4.11

I recently updated cli to version 17.4.9 and observed local deployment for my project got stuck in the build stage without showing any errors. I upgraded to the latest version v17.4.11 and got the same issue. I randomly downgraded to v17.4.5 and it worked very well. How to fix this issue? Do I need to change any configuration for the latest version?

1 Like

Hello, could you please clarify some details:

  1. By “local deployment” you mean balena push {uuid}.local? Could you please clarify the exact command you are running?
  2. Did you try pushing the same release in all versions?
  1. I use balena push <IPaddr> --debug and device is set in the local mode.
  2. Yes, it is not working on v17.4.9 as well but worked on v17.4.5 & 17.4.4. I did not test in between versions.

I’ve been having this issue for a while as well. It looks like someone’s working on it: Revert upgrade to dockerode to avoid regression by kb2ma · Pull Request #2719 · balena-io/balena-cli · GitHub

Hi @Perzade @mike.dean , the PR @mike.dean mentioned has merged. Could you please try CLI version 17.4.12 or 17.5.0 and let us know if the issue is resolved?

Hey…I checked local deployment with v17.4.12 and it’s working!

1 Like

Awesome, glad to hear it! Thank you for confirming. Please let us know if you encounter any other issues.