Integrated C5 Bose-DAC not working

Hello people,

firstable thank to all people who have worked on this app.

I have some troubles on my setup :

  • Bose Companion 5
  • Raspberry Pi 3
  • balenaOS 2.67.3+rev4

My goal was to use RP3 with balena to connect my devices thanks to bluetooth.

I have already put the Define DT parameters “audio=off” as I have seen in some other cases.
But it aint working.

the dmesg on the host show me this :

[  478.750084] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
[  478.928571] usb 1-1.3: New USB device found, idVendor=05a7, idProduct=1020, bcdDevice= 1.00
[  478.928601] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  478.928621] usb 1-1.3: Product: Bose USB Audio
[  478.928640] usb 1-1.3: Manufacturer: Bose Corporation
[  478.976567] snd-rpi-iqaudio-dac soc:sound: ASoC: failed to init link IQaudIO DAC: -517
[  478.987976] hid-generic 0003:05A7:1020.0002: hiddev96,hidraw0: USB HID v1.10 Device [Bose Corporation Bose USB Audio] on usb-3f980000.usb-1.3/input2
[  478.988829] snd-rpi-iqaudio-dac soc:sound: ASoC: failed to init link IQaudIO DAC: -517
[  479.104238] systemd-udevd[91]: controlC0: Process '/usr/sbin/alsactl -E HOME=/run/alsa -E XDG_RUNTIME_DIR=/run/alsa/runtime restore 0' failed with exit code 99.
[  479.133198] systemd-udevd[90]: card0: /etc/udev/rules.d/95-balena-audio.rules:13 Failed to write ATTR{/sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/sound/card0/id}, ignoring: File exists

IDK if I must install other plugins or something, nothing on the web seems like the same problem.

Principaly I would connect phones with Spotify or computer.

thank you in advance for everything.


Hi, can you tell me about your setup ? How are you connecting to the BOSE speaker, and where are you streaming audio from?

Hello @MejiWu ,

This might be pointing to some issue with the USB drivers. Is our assumption that you’re connecting the speakers through USB accurate? It would also be useful to know what you are using as an audio source.

Hello guys,
thank you for your answers,

Bose Speakers are connected with USB directly on the RP3. They have integrated DAC in those speakers.
Sources casting can be, my phone with bluetooth and Spotify, or my computer (Windows 10).

Ok update Info :slight_smile:
I have no more error from dmesg on all terminals after a new Clean install with the balena-sound-master
I can control Balena Spotify form my phone and my computer, but I have no sound…
It’s smell better haha.
No more errors but no sound at all. I have checked master volum, PC and all sources, but no noises nothing :(.

Still working on it.

Now that what i can see from Windows and Host OS



hci0: Frame reassembly failed (-84)

It’s seems like I must buy an external BT dongle…if you have any other ideas :slight_smile:

Hey, Yannick, this is a known issue being actively worked on. You can follow the issue here, and we will let you know when it is fixed as well.

1 Like

Ok good to know.
I’ll follow it,

thx for the link.

Hey, @mejiwu

Good news, We’ve fixed the issue you were experiencing with balenaSound! Please do give it a go and let us know how it is, we’d appreciate your feedback to understand if it did indeed fix the issue for you.

Hello Jazzagi,

I pushed the new balena-sound-master, but it’s the same result. I still have the hci0: Frame reassembly failed (-84) on the Bluetooth apps.

Maybe I should try to look in other place ?

Thx for your support,

good luck

Hey @mejiwu!

Thanks for your patience as we investigate this. Looks like from previous messages that you’re now on the latest balenaSound version (should be 3.5.2).

Let’s also make sure you’re using the latest and greatest balenaOS release for RPi3. This also makes me want to know how your whole setup looks. What other device types do you have on your balenaSound setup? The latest stable version for 32bit Rpi3 is different than 64bit.

Also worth investigating: I’m curious as to what value your AUDIO_OUTPUT environment variable has. By default, the audio block of balenaSound will prioritize USB > DAC > HEADPHONES > HDMI. I’m wondering if this changed or got unset somehow throughout all the troubleshooting.

Ideally it should work as set to AUTO (default setting). Just a hunch here and worth investigating!

Hello @andrewnhem ,

I currently use this on my RP3 :

I have tried x64 and 32bits but it’s the same resulte,


My setup is :
RP3 next to my Bose Speakers connected with the integrated USB.

SOund cast is from Phone Bluetooth with Spotify. Or from my laptop.
SOngs comming from Spotify are seen in logs but tere is no sound.
Same from laptop.

Where I can find AUIO_OUTPUT setting please ?

thx for your help, sorr for the delay, i believe I had already answered


Thanks for sharing the OS and supervisor version - these look good and shouldn’t cause an issue.

The AUDIO_OUTPUT variable can be set from the device env variables setting on the left pane of your devices page. You can find more about the different settings you can set on our docs page

Let us know if setting this makes it work.