Balena Etcher portable v. 1.5 102 windows not recognizing USB stick

Hi all,

I am trying to flash a Linux mint.iso with Etcher; but whenever I select the file, the USB stick is not available as a selection. Are there any reasons for this?

Lexar USB Flash drive 32GB

PC Specs

Intel Atom CPU N270 @ 1.6 GHZ

1GB Ram

32-bit OS

Win-7 Pro


  • have you tried another USB drive?
  • what version of etcher are you using?

I have not tried another USB drive; but what is the reason why my current USB drive will not work? I’m using version 1.5 102.

Hi, is the USB drive appearing under the Windows Device Manager? Is it accessible for other applications like the file explorer?

The USB drive does appear under the Windows Device Manager and it is accessible for other applications.

Hi, thanks for that information. Could you please check if there are additional logs?
On Windows, press ctrl+shift+i, it will open a window called Developer Tools - select the console tab.

I believe the program has issues with large storage USBs (anything more than 8GB) from what I have read from other complaints. So I tried another program and it solved my problem; but thanks for the responses.