flashing PureOS for Mac

I downloaded PureOS from their website and Etcher for Mac iOS. I flashed PureOS onto a USB using Etcher. But the Mac will not boot from the USB. The Mac firmware does not recognize the USB. It does recognize a Mac iOS bootable USB. So it is clear that the flashing, which is done by Etcher is not recognized by the Mac firmware.
I have tried flashing a hard drive with Etcher and then installing the hard drive into the Mac to where it does not have a choice but either run from it or not. It does boot up with the PureOS in safe mode. and runs a live version of PureOS. But I cannot install PureOS on this hard drive, because it wants it to be partitioned.
I wish Etcher could flash a USB stick in a manner that it can be recognized by the Mac firmware and run the PureOS live version. Then I could probably install PureOS on a virgin hard drive from the USB in the same manner I install Mac iOS from a USB unto a virgin hard drive.

Hey there! How are you booting the Mac? As far as I remember, you can restart the Mac while pressing Options, which will get you into a boot menu that lists all the available boot drives, and then you can insert the PureOS drive and select it from there

Pressing the option key while starting the Mac does NOT show all the available boot drives, because the Mac does not recognize what Etcher has done.
After Etcher has flashed any drive, the drive is no longer readable by Mac iOS either.

Keep in mind that it is expected that macOS (i.e. Finder) doesn’t recognise the PureOS drive if you plug it back in, as PureOS uses a GNU/Linux partition scheme that Mac’s can’t understand, but that doesn’t mean your Mac wouldn’t be able to boot from it.

Do you not see the Startup Manager screen (https://support.apple.com/en-gb/HT202796) at all?

No, the USB does not show up in the start up screen at all.

Are you sure that PureOS supports Apple hardware? I did some Googling and I can’t find any documentation that states that it should work. Maybe you can try another Linux distro, such as Ubuntu, and see if that boots? If that works, then probably PureOS will not work on a Mac

Yes it does to a good degree. I flashed a hard drive and then installed the hard drive into the Mac. That way the Mac has no choice but to boot from it or don’t boot at all. I was able to run the live PureOS on the Mac. It did not find my wifi card, but I have a USB wifi available and got online.
Unfortunately the live PureOS cannot install itself on the same hard drive it runs from. Apparently it is not able to partition the drive it is running from


Although I run linux and not macosx, I’ve just tried flashing PureOS ISO on a pendrive using etcher.
When I booted, my BIOS didn’t even listed my pen drive as a boot option.
I had to disable UEFI and reboot: only then my pen drive showed up and I could boot PureOS
Can you retry after having disabled UEFI on your mac?

After some googling, we’ve also found an alternative [1]: here, EFI files are provided, so you can add an UEFI partition to the pen drive to make it bootable

[1] https://nabeards.com/posts/pureos-install/

Best regards


Thanks federico.
The laptop I am using at this moment cannot open your link to nabeards.com
I purchased the Mac Linux USB Loader from sevenbits.io But this one is also an incomplete tool. It creates the EFI on the USB stick but then lacks to finish the job. I followed their link to https://sevenbits.github.io/Enterprise/ , which is connected with the Mac Linux USB loader. Apparently the Loader and Enterprise go together but Matt Bowring seems like has not completed the programming yet.

Hi @Ralf,

I suspect that your browser couldn’t open the link to nabeards.com as that website is missing a valid TLS certificate. Using Firefox or Chrome you could ignore the browser warning to load that website if you’d like.

Since Federico managed to reproduce the issue and find a solution, I’m not sure how we could help out further here. Anyhow, this issue doesn’t seem like an Etcher problem to begin with.

Good luck.

I will try the instructions on nabeards.com.
If Etcher would create the EFI on the USB stick before it copies the PureOS installer on there, it may work. But right now it only does part of the job necessary to create a bootable USB.

My last reply was blocked.

Hi Ralf,
can you repost your last reply, so we can respond ?
Regards Thomas

No, I cannot repost the reply, because this forum does not allow me to.
I tried.

Hi Ralf, I marked your posts allowed, but I’m not sure if they are properly reflected in the thread. Can you re-iterate what you tried. I think the design of etcher is to not do any thing prescriptive with disk image, it just does a raw copy directly and doesn’t know anything about EFI or specifics of images, so I think making it understand that would need some significant rearchitecting if I understand it correctly.

I don’t know what exactly the Etcher is doing, since I cannot read the drive anymore with the Mac, once the etcher has done the flashing.
I also don’t know what the goal was, what the Etcher is supposed to do. But since it is specifically designed to run on Mac and Apple iOS, I was hoping that it would produce a bootable USB drive. How else could one install PureOS other than from a USB?
I have learned that a bootable USB for a Mac requires the EFI partition. If I can figure out a way to get the install file for PureOS onto the EFI partition, I may be able to install it.
My next step is trying to find a way to read a drive that has been flashed by Etcher. If I get that done, I may be able to copy the flash onto the EFI partition.
I have also tried the Mac Linux USB installer form Sevenbits, but without success. And their original programmer is gone, so they couldn’t help either.
The error message I got trying nabeards instructions look similar to what I got from the Mac Linux USB installer. But at least I learned about the necessity of the EFI partition.

Hi Ralf,
Etcher will burn an image to an SDcard - that is all. It will not make any modifications and in terms of EFI boot capability - your SDcard will only be as good as your source image.
The instructions on nabeards.com. allow you to create a MAC bootable thumbdrive, use that to boot and then install the pureOS image from a second drive that contains the pureOS image burned using etcher. So Etcher is not really the culprit here, you will have to try create the MAC boot thumbdrive using instructions from nabeards.com. or as ffissore indicated further up disable EFI on your mac and boot directly from the pureOS stick.
Cheers Thomas

As I said, I tried the instructions form nabeard and got an error message.
I tried disabling EFI on my Mac but since it does not have the T2 chip, the disabling is not available.
The Etcher will burn an image to an SDcard. What exactly does “burn an image” mean. What does it do to the PureOS.iso file that it is using for the burning?

Etcher flashes the chosen image byte-to-byte to the target, which means that it reads the data contained in the image and writes it directly, without modifications.
For this reason, it’s not the best option when it comes to bootable USBs as they typically require additional steps/changes which Etcher doesn’t perform, so you’ll have to do them manually based on what the image needs. In other words, you need to follow the guide of the OS you mentioned. I have no experience with it unfortunately, so the best I can suggest is to check if there’s more information about this operation on the internet, as Etcher can’t go that far (yet) - it can only flash the image.
You can also find more information in our documentation here

Thanks thundron.
But Etcher also formats the drive, which prevents flashing any partition.