Flashed onto SD card without issue, SD card is not booting or appearing in boot menu


I’m running Linux, I used Etcher (version 1.5.113) to flash an image from a URL onto an SD card. It went to 100% completion without any issue. I know the image works. My file manager reads the SD just fine, can see 2 partitions, and mounts and opens them just fine. The SD card is not showing up in my boot options and I can’t get it to boot.

What are the next steps I should try? Anything basic I may have forgotten to do?

Thank you for taking the time to read this.

Hello Rigi,
are you trying to boot with your SD Card into your Laptop or into a device?
If it is a Laptop, BIOS/UEFI should recognize your integrated SD Card reader as a USB Port (so add Boot from USB to the top of the boot order)
If it is another type of Device, what type is it?

Regards Juan

Hey Juan!

I’m using an SD card. I’m booting into a laptop. I entered the boot settings and while it reads any USB I have inside (regardless if it’s bootable or not), it does not read the SD card. The boot settings offer UEFI and Legacy, I tried them both, no luck.

I know the image I’m using is OK because I am running a live USB using that same image, works just fine.

The more I think about this, the more I think it is an issue with my laptop and/or it’s boot settings rather than an issue with Etcher.

In any case, thank you for your time, let me know if there is any other information you need and/or if there is a test I should do.

Hey Rigi, no worries glad to help. If your Laptop is reading USBs… have you tried flashing the image into a USB stick and boot it from there?

It’s the latest release of Kali. I downloaded it on a Windows platform and made a live persistent USB with Rufus. I have used that USB in 3 different computers (and am using it as I type) and it works just fine. It is that exact same image I etched onto the SD card.

This time I am not using a USB, Windows, Rufus, and an already downloaded iso. I am instead using an SD card, Linux, BalenaEtcher and the URL link (I really liked the “download from URL” feature of Balena). But the image itself is the exact same one, so I can be sure it’s not faulty.

Update: After some digging around the web for more info, and going over existing evidence, I believe the most likely scenario is that my Lenovo simply can’t boot SD cards with its factory booting software. That would mean it’s not a BalenaEtcher issue.