Flash SD Finished with a failed target

I was trying to flash a Linux Mint iso onto an SD card, and after it completed the validation, it says that the flash was completed, but with a failed target. I can’t tell if it worked or it didn’t work, as I’m not getting the same error message everyone else seems to have.

This screenshot seems like a very old version of etcher.
Can you share the version of etcher number and your OS name/version?
Can you try with a recent etcher version like Release v1.13.3 · balena-io/etcher · GitHub ?

Hello. I have had the same problem just now while using 1.13.3. I have tried multiple thumb drives to no avail.

I finally got it to work. Apparently Etcher does not like drives larger than 8GB. I tried a 64GB, 128, and 256 and they all failed. The 8GB worked just fine.

Perhaps something was an issue with the downloaded image or an odd case of all other drives being corrupt . I can confirm that I have used Etcher to flash 16GB and 32GB flash drives. I am not aware of any size restrictions of etcher.