Etcher failed and SD card is now unreadable...

Hello,
I am hoping someone on here can assist me, I am new to the Etcher community but I have used it a couple of times with success prior to this attempt.
I was attempting to place the 128 GB RetroPi build from Arcadepunks onto an SD card, but after a couple of minutes I received a message stating that the operation had failed. I was going to attempt again, but it told me there was no longer a device. I went to windows file manager and sure enough my SD card was no longer reading. I tried taking it out and replacing into the usb port, but it still would not read it, I tried another USB stick adapter and got the same results. This is a brand new card that was working prior to the attempt. Please help me, can the card be restored so I can still use it or has something horrible occurred?
Thank you in advance for your help.

Hi
Is it possible for you to try this device on another OS or machine?

Sorry I took so long to get back. I am in the process of building a desk and my PC was kinda in the corner, lol.
So I had been looking through the forums looking for anyone with a similar issue and I saw where someone had suggested trying Minitool partition wizard, so I figured I had nothing to lose. It in fact did see the card, apparently what had happened was before the failure, etcher had written a partial MBR to the card, causing windows to no longer recognize it.
So I deleted the MBR and reset the partition to simple, formatted and boom windows sees it again.
Now, the question is, why did it fail? I am thinking it is because I ran out of HD space. At the time I did not realize that I only had 99 GB free and the file is 113 GB, now I’m not sure the exact process Etcher uses, but that space is after I had the file on my HD, does Etcher require you to have additional space beyond the files size in order to do what it does to make the card into a bootable drive? The card is 128 GB as the site says to use for that version of Retropi.
I have recently also upgraded my HD, so I will try again and see if that was the issue, but it will be a couple of days, as I am not able to until the desk is complete and I hook everything back up.
So what do you think? Was that the issue?

Hey Bowdiddly, it doesn’t seems that the issue is related to the size of hard drive, since Etcher just writes data byte-to-byte directly on the HD, so if you have enough space as the image you want to write, then it should be written properly. If this happens again, then to get a clear view we will have to look into the logs, while the process is running.

Hi,
I have an similar problem as described by Bowdiddly. I wanted to flash a 21 GB file to a 64 GB Micro SD card. So I have enough space. Before starting to flash I formated the card with the SD Memory Card Formatter. A few seconds after beginning the flashing process on Etcher a error message appears and the SD card is unreadable. The message in the LOG is:

Failed to load resource: net::ERR_FILE_NOT_FOUND

I already tried it multiple times on different Laptops.
I think my issue fits to this thread. Hopefully anyone can help. Thank you!

I am about to try again, but now I’m wondering if it’s an Etcher issue. It will take awhile to know if it works, but either way I’ll post my results.
Erik, if you are familiar with how partitions work, you could try to use minitool like I did to recover your card.

Hi @erik_munich It shouldn’t be necessary to pre-format the SD card before running balenaEtcher. Are you able to see partition(s) using your disk partitioning tool (Gparted, diskpart.exe, etc.)? This document may provide some other ways to check the health of the disk itself. https://github.com/balena-io/etcher/blob/master/docs/USER-DOCUMENTATION.md#recovering-broken-drives

Sorry it took so long, some things came up, like a blown radiator hose in the walmart parking lot. Anyway. Now it fails immediately and just says operation not permitted, write. But it destroyed the partition first. There is not a lock on this card or the adaptor. What am I doing wrong?

It asks for the image, I select it, it asks for the drive, I select it. The image is 121 GB, the card is 128 GB. Only thing it does is after I select the card, it tells me that it’s unusually large for a card??? Who even thought to put that in the code? Smh.

Any thoughts?

I finally went and got the new pi imager and wrote rasberrian to the card, stuck it in the pi and boom booted right up.

I am currently trying the larger image with it, but I’m not seeing any progress so I’m thinking it may be stuck, dunno yet.

I did notice something curious though, every time it fails in Etcher, it goes to the same exact time left count, then fails. Do you have a max time to write limit? It’s a very large number in minutes, I can’t recall it right off, but somewhere in the 500,000 range, I believe? Could be wrong, but since I’m currently trying the pi imager, I can’t check.

Another thing to check for would be the integrity of the retropi image. On their page they have md5ums underneath the download buttons. Can you see if your image matches that?

Hi,

Were you able to get this sorted? Please let us know if there’s anything we might do from our end.

Best regards,
John

Thank you guys for picking your brains for me. Sorry, I haven’t gotten back sooner. I ended up ordering a 256 GB card. I took all the advice here, I took the 128 GB card, formatted xfat, ran Etcher in admin mode and it worked for the 64 GB image. The card worked wonderfully in the Rasberry Pi 4b 4GB version.
I finally got the 256 GB card a few days ago, I formatted xfat, ran in admin mode and the second try, it worked. The card boots and runs fine.
Idk why for me I had to get larger cards than was recommended, but that’s the way it worked out.
So I guess it worked out. Was a frustrating but learning experience.
Thank you to everyone who tried to help me. It all helped!