Fix found: Etcher bluescreens when starting validation

I was trying to flash an image to a microSD card and my laptop would repeatedly bluescreen when it started the validation step. I was previously using my laptop’s built-in microSD card reader. When I instead used a USB-based microSD card adapter it worked fine! Just thought I would share in case this helps anyone else.

Extra info:
Etcher version: 1.7.9
Laptop OS: Windows 11, build 22000.978
Laptop hardware: Microsoft Surface Pro 7
Image to be flashed:

The bluescreen error messages varied. I had KERNEL_MODE_HEAP_CORRUPTION and SYSTEM_THREAD_EXCEPTION_NOT_HANDLED. Also once I tried to reflash to the microSD card but I think it was corrupted. That time I got PAGE_FAULT_IN_NONPAGED_AREA.


thanks for the info it is a really interesting and valuable report.
I am glad you have a workaround with the USB adapter.

Looking into the issue and trying to find the main differences and the specs of the SD reader in the Surface Pro 7, I found a lot of tickets about misbehaving SD readers in the Surface Pro 7. Can you confirm your SD reader is working well (reading, writing, formatting sdcards from windows explorer) outside etcher?

For the retry of flashing the card which then looks corrupted, did you try any of the methods described here
Etcher broke my USB stick … or did it? ?