etherbalena killed my usb

Tried to install Linux Mint and installed balenaEtcher for first time but just killed my USB it switched to Raw format… im trying couple of ways through but none is working…

Can you help me out?

Sorry to hear that. Just to clarify; when you say USB is in RAW format - is that not detected on the system when plugged in? Can you try if on Linux/Mac:

$> lsblk

Plug the USB, and run command again:

$> lsblk

Note: First level of hierarchy represents devices, and second level represents the partitions inside that device.

If it is detected; you can then followup to delete the content off of /dev/sdX and create a fresh partition table. Then format it to desired format:


$> sudo mkfs.vfat -F 32 /dev/sdX0


$> sudo mkfs.ntfs -f /dev/sdX0

Here is what I could find for Win platform: How to Recover Data from RAW USB [2022, Easy Steps]

Also, it would be great to know about the host OS your tried this from and the etcher

Pretty sure it has nothing to do with Balena.
If you flash a usb driver with a Linux system, the usb filesystem will be changed to ext4 and Windows cannot read this by default.
That is generally why you don’t see anything on your usb drive anymore. But that doesn’t mean that the usb driver is dead.

You can use SD Memory Card Formatter | SD Association to do a quick format and get back your usb driver to FAT or NTFS filesystem that are readable by windows and most of the other devices. It also work for sd cards !

1 Like